Ignore_malformed doesn't work?


(Daniel McGreal) #1

Hi,
I'm using 5.2.2 and have set my index's settings.index.mapping.ignore_malformed to true (I have verified this) and yet when I index a document I get a document rejected because it tries to put an object where it's expecting a string.

Does ignore_malformed only work for some cases?

Best, Dan.


(Alexander Reelsen) #2

Hey,

indeed it currently only works, if you specify a field that does not contain an inner field, but just a different type. There is already an issue about this https://github.com/elastic/elasticsearch/issues/12366

You should be able to work around this by setting object: false (but this needs to be done on a per-field base).

--Alex


(Daniel McGreal) #3

Thanks!


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.