Ignoring the 'pipelines.yml' file because modules or command line options are specified - RPM

i have installed logstash through RPM on my ec2 instance and started < ./logstash --path.settings /etc/logstash/ --path.config /etc/logstash/ /> but i see below error. Can someone help out here?

[root@ip-10-1-1-133 bin]# ./logstash --path.settings /etc/logstash/ --path.config /etc/logstash/ -e
OpenJDK 64-Bit Server VM warning: If the number of processors is expected to increase from one, then you should configure the number of parallel GC threads appropriately using -XX:ParallelGCThreads=N
Sending Logstash logs to /var/log/logstash which is now configured via log4j2.properties
[2019-05-31T22:24:41,524][WARN ][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified
[2019-05-31T22:24:41,557][INFO ][logstash.runner ] Starting Logstash {"logstash.version"=>"7.1.1"}
[2019-05-31T22:24:43,632][ERROR][logstash.agent ] Failed to execute action {:action=>LogStash::PipelineAction::Create/pipeline_id:main, :exception=>"LogStash::ConfigurationError", :message=>"Expected one of #, input, filter, output at line 6, column 1 (byte 132) after ## JVM configuration\n\n# Xms represents the initial size of total heap space\n# Xmx represents the maximum size of total heap space\n\n", :backtrace=>["/usr/share/logstash/logstash-core/lib/logstash/compiler.rb:41:in compile_imperative'", "/usr/share/logstash/logstash-core/lib/logstash/compiler.rb:49:incompile_graph'", "/usr/share/logstash/logstash-core/lib/logstash/compiler.rb:11:in block in compile_sources'", "org/jruby/RubyArray.java:2577:inmap'", "/usr/share/logstash/logstash-core/lib/logstash/compiler.rb:10:in compile_sources'", "org/logstash/execution/AbstractPipelineExt.java:151:ininitialize'", "org/logstash/execution/JavaBasePipelineExt.java:47:in initialize'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:23:ininitialize'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline_action/create.rb:36:in execute'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:325:inblock in converge_state'"]}
[2019-05-31T22:24:44,213][INFO ][logstash.agent ] Successfully started Logstash API endpoint {:port=>9600}
[2019-05-31T22:24:48,975][INFO ][logstash.runner ] Logstash shut down.

pipelines.yml in /etc/logstash directory

-pipeline.id: access_logs
path.config: "/etc/logstash/pipelines/access.conf"
-pipeline.id: error_logs
path.config: "/etc/logstash/pipelines/errors.conf"

You have specified --path.config on the command line, so it will ignore pipelines.yml. Instead it loads every file it can find in the directory you specified, which include jvm.options -- that is what results in that error message.

what's solution here ?

same error when i do this

./logstash --path.settings /etc/logstash/ --path.config /etc/logstash/pipelines.yml

Remove --path.config from the command line.

then i face this issue

ERROR: Failed to read pipelines yaml file. Location: /etc/logstash/pipelines.yml

Do you think there is something wrong with the pipelines.yml content ?

ah the issue is with pipelines.yml content ther should be space after '-'

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.