Illegal characters in elasticsearch field names


(Eliezer Shindler) #1

Hi,

Besides from special characters, elasticsearch also does not seem to allow
other characters in fild names, such as <,> and a comma. Could anyone
please provide me with a full list of illegal characters for field names.

Many thanks,

Eli

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/b113635c-3b53-4ba7-9bd2-4ca554737282%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


MapperParsingException[Failed to parse mapping...]
Unknown filed type is not mapped
(Jörg Prante) #2

Special characters in Elasticsearch field names are:

. (for navigation between name components)

(for delimiting name components in _uid, should work, but is discouraged)

  • (for matching names)

There are also some restrictions on type names for mappings:

  • must not start with underscore "_"
  • must not contain comma ","
  • must not contain hash mark "#"
  • usage of point "." is discouraged but possible

Jörg

On Fri, Apr 25, 2014 at 1:42 PM, Eliezer Shindler <eliezershindler@gmail.com

wrote:

Hi,

Besides from special characters, elasticsearch also does not seem to allow
other characters in fild names, such as <,> and a comma. Could anyone
please provide me with a full list of illegal characters for field names.

Many thanks,

Eli

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/b113635c-3b53-4ba7-9bd2-4ca554737282%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/b113635c-3b53-4ba7-9bd2-4ca554737282%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKdsXoHbWGfCCNbq_vUA7EDTNs-2%3DsnbqVVs89mHD0c9YF6NQg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Eliezer Shindler) #3

Thank you.

On Friday, 25 April 2014 13:56:19 UTC+1, Jörg Prante wrote:

Special characters in Elasticsearch field names are:

. (for navigation between name components)

(for delimiting name components in _uid, should work, but is discouraged)

  • (for matching names)

There are also some restrictions on type names for mappings:

  • must not start with underscore "_"
  • must not contain comma ","
  • must not contain hash mark "#"
  • usage of point "." is discouraged but possible

Jörg

On Fri, Apr 25, 2014 at 1:42 PM, Eliezer Shindler <eliezer...@gmail.com<javascript:>

wrote:

Hi,

Besides from special characters, elasticsearch also does not seem to
allow other characters in fild names, such as <,> and a comma. Could anyone
please provide me with a full list of illegal characters for field names.

Many thanks,

Eli

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/b113635c-3b53-4ba7-9bd2-4ca554737282%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/b113635c-3b53-4ba7-9bd2-4ca554737282%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/efe1550c-2888-49c2-b85d-1abb1f45016c%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #4