Illegal reflective access errors

Getting Illegal reflective access errors along with these warnings:



WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by org.jruby.ext.openssl.SecurityHelper (file:/{...}/jruby{...}jopenssl.jar) to field java.security.MessageDigest.provider
WARNING: Please consider reporting this to the maintainers of org.jruby.ext.openssl.SecurityHelper
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release

Tried these solutions but none of them are working:

Can anyone help here?

Thanks in advance.

When you start logstash you should get a "Starting Logstash" message that reports the logstash and jruby version. What does it show?

JRUBY_VERSION="9.3.8.0"
LOGSTASH="8.4.3"

See here. Some of the underlying access errors in SecurityHelper were fixed in JRuby 9.3, but apparently not all.

Yes, i have tried these but still not working. It is also pasted in my question.

OK, so as the message says, report it to the maintainers of org.jruby.ext.openssl.SecurityHelper. They are the folks who can fix it.

Hi @Badger ,
Can you help me how to report them?