ILM issue


I am trying to set up an ILM policy for the data I am having in my ES.
I am getting the below exception.

illegal_argument_exception: index name [logstash] does not match pattern '^.*-\d+$'.

when I do

GET /_aliases?pretty

I get (part of the output)

"logstash" : {
"aliases" : {
"lg-1" : { }

Any updates on this issue?

How are you setting up the policy? Which version of the stack are you using?

I believe you're getting that error when rolling over? That's because your index name doesn't have the numerical ending (eg. logstash-000001).
I believe your index bootstrapping was not correct either because the alias doesn't have the is_write_index option configured to true (see Tutorial: Automate rollover with ILM | Elasticsearch Guide [7.13] | Elastic fro more details on bootstrapping).

Alternatively, use data streams to avoid these bootstrapping and naming nuances.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.