Ilm policy error

I have been trying to set up ilm policy for my indexes for several weeks now. I use filebeat in conjunction with logstash and my indexes end up being created every day.

An example of my index name:

I have an index template which for each
makes adjustments, I remove some fields, add dynamic mapping and so on.

In addition I have ilm_policy: general, in which are configured sections hot, warm, delete

In the index template I specified:

But I keep getting errors at the check-rollover step. After looking at similar questions, I realized that I need to specify the first index manually ( with the parameter 'is_writre_index: true') and add a counter type 000001, 000002 and so on at the end, so elastic can rollover my indexes correctly.

Example of a manually created index:

But the problem is the following, logs don't go into this file and logstash creates a new index without a counter. And here I don't understand how I can link this so that my indexes that are created every day use ilm_policy and work correctly

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.