ILM setting in beats configuration


I am seeing ilm errors in my Elastic search. I am currently using beats 6.7 version.
I am planning to install version 7 now. I got to know that filebeat has to create an alias while creating an index.

I see the below configuration in Filebeatreferance.yml but not in filebeat.yml file.

So if this setting is not mentioned in filebeat.yml does it create default alias name as filebeat.versionname in version 7.

#============================== Setup ILM =====================================

# Configure Index Lifecycle Management Index Lifecycle Management creates a
# write alias and adds additional settings to the template.
# The elasticsearch.output.index setting will be replaced with the write alias
# if ILM is enabled.

# Enabled ILM support. Valid values are true, false, and auto. The beat will
# detect availabilty of Index Lifecycle Management in Elasticsearch and enable
# or disable ILM support.
setup.ilm.enabled: auto

# Configure the ILM write alias name.
setup.ilm.rollover_alias: "filebeat"

# Configure rollover index pattern.
setup.ilm.pattern: "{now/d}-000001"

No, you need to copy over the settings into the filebeat.yml for them to be applied.

Thanks for the quick reply. Why is it not mentioned as default in filebeat.yml file as other configurations.

We put a basic set of config options in the default filebeat.yml and everything in the reference file.

If you'd like to see the ILM config in the default config file then please feel free to raise a feature request on GitHub :slight_smile:

Sure, Thank you.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.