ILM - Warm phase index is showing up in Hot phase

Team, One of the index i have created with routing policy set to warm but under the Lifecycle status the index is showing up under Hot. Any idea why it is showing in Hot when it is expected to show only in Warm. Please advise if there is any config to be done

"routing": {
"allocation": {
"require": {
"data": "warm"

Welcome to our community! :smiley:

Please share your entire policy as well as your index template.


Attached file Below is the index template setting

{
"index": {
"lifecycle": {
"name": "right-now"
},
"routing": {
"allocation": {
"require": {
"data": "warm"
}
}
},
"refresh_interval": "30s",
"number_of_shards": "1",
"number_of_replicas": "1",
"merge": {
"scheduler": {
"max_thread_count": "1"
}
}
}
}

Any update on this request?

The image you show has the warm phase disabled from what I can see?

@warkolm If we do not enable warm phase, by default where does the data go, in hot phase? is it how it works.... The routing allocation is mention as warm

routing": {
"allocation": {
"require": {
"data": "warm"

I think we'd need to see a bit more of your settings, as formatted json please :slight_smile:

@warkolm which specific setting you want to see, the index template one?

And the ILM policy, and an _explain on the policy please.

@warkolm I have already provided the JSON mapping and the ILM settings on my previous update. Please guide me the navigation what you are requesting for. The index name is right-now and the pattern is right-now-*, this index was supposed to be in warm phase under the life cycle phase. When i select as Hot in life cycle phase, i can see the right-now index populating, which ideally shouldn't come up. I can't see it in warm phase

Any update?

Unfortunately you've only shown us snippets of what we need to see, hence why I asked for what I did.