Implicit match all when using not filters

Besides working on projects using ElasticSearch, I am still using on Lucene
as well. One limitation of Lucene is that a query or sub-query cannot
continue only NOT clauses. The common workaround is to ask for everything
: when using a NOT clause.

I believe ElasticSearch does this automatically when using NOT clauses. I
am looking to borrow coughstealcough some ideas, but I can't figure
where exactly in the code this magic is happening. Anyone have any ideas
where it could be? Imitation is the sincerest form of flattery.

Cheers,

Ivan

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

On Thursday, April 4, 2013 1:56:12 PM UTC-4, Ivan Brusic wrote:

Besides working on projects using ElasticSearch, I am still using on
Lucene as well. One limitation of Lucene is that a query or sub-query
cannot continue only NOT clauses. The common workaround is to ask for
everything : when using a NOT clause.

I believe ElasticSearch does this automatically when using NOT clauses. I
am looking to borrow coughstealcough some ideas, but I can't figure
where exactly in the code this magic is happening. Anyone have any ideas
where it could be? Imitation is the sincerest form of flattery.

Cheers,

Ivan

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Thanks so much. I was looking in the Builder classes, while the call was in
the parser instead.

I knew I would learn something. My code is pretty much identical, except I
didn't know about the existence of isProhibited(). Not sure how I missed it
after many years of using Lucene.

--
Ivan

On Fri, Apr 5, 2013 at 6:51 AM, Igor Motov imotov@gmail.com wrote:

https://github.com/elasticsearch/elasticsearch/blob/4eefcb9c82778e8cd7a0126b98872cf08740c46e/src/main/java/org/elasticsearch/common/lucene/search/Queries.java#L103

On Thursday, April 4, 2013 1:56:12 PM UTC-4, Ivan Brusic wrote:

Besides working on projects using ElasticSearch, I am still using on
Lucene as well. One limitation of Lucene is that a query or sub-query
cannot continue only NOT clauses. The common workaround is to ask for
everything : when using a NOT clause.

I believe ElasticSearch does this automatically when using NOT clauses. I
am looking to borrow coughstealcough some ideas, but I can't figure
where exactly in the code this magic is happening. Anyone have any ideas
where it could be? Imitation is the sincerest form of flattery.

Cheers,

Ivan

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.