Include_in_all for boolean types


(sezgin küçükkaraaslan) #1

Hi,
I'm using the 0.13.0 version of elasticsearch and noticed that
"include_in_all" setting does not seem to work for boolean types. Here is
the mapping that I put for my index:

{
"type3":{
"_all":{"enabled":true,"analyzer":"rossWhitespace"},
"properties":{
"prop7":{"include_in_all":true,"store":"no","type":"date"},
"prop8":{"include_in_all":true,"store":"no","type":"boolean"}
}
}
}

"rossWhitespace" is an analyzer that I construct with the following
settings:

index.analysis.analyzer.rossWhitespace.tokenizer: whitespace
index.analysis.analyzer.rossWhitespace.filter.0: lowercase

Here is the mapping that I get when I call the get mapping rest api:

{
"testindex2":{
"type3":{
"properties":{

"prop7":{"include_in_all":true,"format":"dateOptionalTime","type":"date"},
"prop8":{"type":"boolean"}
},
"_all":{"analyzer":"rossWhitespace"}
}
}
}

Nothing is changed when I set "include_in_all" to "false" eighter.

Regards,
Sezgin Kucukkaraaslan
www.ifountain.com


(Shay Banon) #2

Boolean fields don't participate in include_in_all, I though that it does
not make sense, but have no problem with enabling it if you think it does.

2010/11/26 sezgin küçükkaraaslan sezo104@gmail.com

Hi,
I'm using the 0.13.0 version of elasticsearch and noticed that
"include_in_all" setting does not seem to work for boolean types. Here is
the mapping that I put for my index:

{
"type3":{
"_all":{"enabled":true,"analyzer":"rossWhitespace"},
"properties":{
"prop7":{"include_in_all":true,"store":"no","type":"date"},
"prop8":{"include_in_all":true,"store":"no","type":"boolean"}
}
}
}

"rossWhitespace" is an analyzer that I construct with the following
settings:

index.analysis.analyzer.rossWhitespace.tokenizer: whitespace
index.analysis.analyzer.rossWhitespace.filter.0: lowercase

Here is the mapping that I get when I call the get mapping rest api:

{
"testindex2":{
"type3":{
"properties":{
"prop7":{"include_in_all":true,"format":"dateOptionalTime","type":"date"},

                "prop8":{"type":"boolean"}
          },
          "_all":{"analyzer":"rossWhitespace"}
      }
 }

}

Nothing is changed when I set "include_in_all" to "false" eighter.

Regards,
Sezgin Kucukkaraaslan
www.ifountain.com


(sezgin küçükkaraaslan) #3

That would be great. Thanks...

Sezgin Kucukkaraaslan
www.ifountain.com

On Fri, Nov 26, 2010 at 10:34 PM, Shay Banon
shay.banon@elasticsearch.comwrote:

Boolean fields don't participate in include_in_all, I though that it does
not make sense, but have no problem with enabling it if you think it does.

2010/11/26 sezgin küçükkaraaslan sezo104@gmail.com

Hi,

I'm using the 0.13.0 version of elasticsearch and noticed that
"include_in_all" setting does not seem to work for boolean types. Here is
the mapping that I put for my index:

{
"type3":{
"_all":{"enabled":true,"analyzer":"rossWhitespace"},
"properties":{
"prop7":{"include_in_all":true,"store":"no","type":"date"},

"prop8":{"include_in_all":true,"store":"no","type":"boolean"}
}
}
}

"rossWhitespace" is an analyzer that I construct with the following
settings:

index.analysis.analyzer.rossWhitespace.tokenizer: whitespace
index.analysis.analyzer.rossWhitespace.filter.0: lowercase

Here is the mapping that I get when I call the get mapping rest api:

{
"testindex2":{
"type3":{
"properties":{
"prop7":{"include_in_all":true,"format":"dateOptionalTime","type":"date"},

                "prop8":{"type":"boolean"}
          },
          "_all":{"analyzer":"rossWhitespace"}
      }
 }

}

Nothing is changed when I set "include_in_all" to "false" eighter.

Regards,
Sezgin Kucukkaraaslan
www.ifountain.com


(Shay Banon) #4

Can you open an issue for this, just that I don't forget...

2010/11/29 sezgin küçükkaraaslan sezo104@gmail.com

That would be great. Thanks...

Sezgin Kucukkaraaslan
www.ifountain.com

On Fri, Nov 26, 2010 at 10:34 PM, Shay Banon <shay.banon@elasticsearch.com

wrote:

Boolean fields don't participate in include_in_all, I though that it does
not make sense, but have no problem with enabling it if you think it does.

2010/11/26 sezgin küçükkaraaslan sezo104@gmail.com

Hi,

I'm using the 0.13.0 version of elasticsearch and noticed that
"include_in_all" setting does not seem to work for boolean types. Here is
the mapping that I put for my index:

{
"type3":{
"_all":{"enabled":true,"analyzer":"rossWhitespace"},
"properties":{
"prop7":{"include_in_all":true,"store":"no","type":"date"},

"prop8":{"include_in_all":true,"store":"no","type":"boolean"}
}
}
}

"rossWhitespace" is an analyzer that I construct with the following
settings:

index.analysis.analyzer.rossWhitespace.tokenizer: whitespace
index.analysis.analyzer.rossWhitespace.filter.0: lowercase

Here is the mapping that I get when I call the get mapping rest api:

{
"testindex2":{
"type3":{
"properties":{
"prop7":{"include_in_all":true,"format":"dateOptionalTime","type":"date"},

                "prop8":{"type":"boolean"}
          },
          "_all":{"analyzer":"rossWhitespace"}
      }
 }

}

Nothing is changed when I set "include_in_all" to "false" eighter.

Regards,
Sezgin Kucukkaraaslan
www.ifountain.com


(system) #5