Include special Symbol


(Nick Chang-2) #1

Hello

I have column include special symbol.
Ex:
user : (Google)abc@gmail.com

I want to count.

POST /datas/_search
{
"facets": {
"terms": {
"terms": {
"field": "user",
"size": 10
}
}
}
}

But, result is not right.
"term": "gmail.com",
"count": 564987
},
{
"term": "facebook",
"count": 475632
},
{
"term": "google",
"count": 411384

Can I to solve this problem??

Thanks

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/532e8f3c-a643-452d-934c-b71774201f18%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Binh Ly-2) #2

You'll likely need that field to be unanalyzed (i.e. tell ES not to cut it
up in the index). One way is to predefine that field in your mapping as:

"user": {
"type": "string",
"index": "not_analyzed"
}

More details here:

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/mapping-core-types.html

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/805a1632-7e84-416f-8d7a-d5b9f327b8aa%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Nick Chang-2) #3

Hello Binh

I used elasticsearch-river-mongo plugin.

How to modify this index??
Thanks for your reply

Binh Ly於 2014年2月26日星期三UTC+8下午11時03分29秒寫道:

You'll likely need that field to be unanalyzed (i.e. tell ES not to cut it
up in the index). One way is to predefine that field in your mapping as:

"user": {
"type": "string",
"index": "not_analyzed"
}

More details here:

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/mapping-core-types.html

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/96a3b201-adef-4fc8-95da-96633ffa6112%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Nick Chang-2) #4

Hello

I already solve this problem. Your suggest is right.

Thanks
Nick

Binh Ly於 2014年2月26日星期三UTC+8下午11時03分29秒寫道:

You'll likely need that field to be unanalyzed (i.e. tell ES not to cut it
up in the index). One way is to predefine that field in your mapping as:

"user": {
"type": "string",
"index": "not_analyzed"
}

More details here:

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/mapping-core-types.html

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/c7005059-e547-460e-a37c-fa1f6a020947%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #5