Including alias creation command while creating setting and mapping


(Amit Soni) #1

Hi everyone - Would you know the command which would enable me to create
the index while I am creating settings and mapping?

Here is what I am executing:

{
"settings": {
...............
},
"mappings": {
....
},
"aliases" : ["my_alias"]
}

however this does not work and no alias gets created. also I get no error.

thoughts?

-Amit.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #2

I think you are looking for this: https://github.com/elasticsearch/elasticsearch/issues/1695

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 14 novembre 2013 at 18:54:25, Amit Soni (amitsoni29@gmail.com) a écrit:

Hi everyone - Would you know the command which would enable me to create the index while I am creating settings and mapping?

Here is what I am executing:

{
"settings": {
...............
},
"mappings": {
....
},
"aliases" : ["my_alias"]
}

however this does not work and no alias gets created. also I get no error.

thoughts?

-Amit.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Amit Soni) #3

yes exactly.

David - Since it is not working for me yet, does the ordering matter?

-Amit.

On Thu, Nov 14, 2013 at 9:59 AM, David Pilato david@pilato.fr wrote:

I think you are looking for this:
https://github.com/elasticsearch/elasticsearch/issues/1695

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 14 novembre 2013 at 18:54:25, Amit Soni (amitsoni29@gmail.com//amitsoni29@gmail.com)
a écrit:

Hi everyone - Would you know the command which would enable me to create
the index while I am creating settings and mapping?

Here is what I am executing:

{
"settings": {
...............
},
"mappings": {
....
},
"aliases" : ["my_alias"]
}

however this does not work and no alias gets created. also I get no error.

thoughts?

-Amit.

You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #4

You should have notice that this issue is not closed.
That means it's not available yet.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 15 novembre 2013 at 03:38:50, Amit Soni (amitsoni29@gmail.com) a écrit:

yes exactly.

David - Since it is not working for me yet, does the ordering matter?

-Amit.

On Thu, Nov 14, 2013 at 9:59 AM, David Pilato david@pilato.fr wrote:
I think you are looking for this: https://github.com/elasticsearch/elasticsearch/issues/1695

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 14 novembre 2013 at 18:54:25, Amit Soni (amitsoni29@gmail.com) a écrit:

Hi everyone - Would you know the command which would enable me to create the index while I am creating settings and mapping?

Here is what I am executing:

{
"settings": {
...............
},
"mappings": {
....
},
"aliases" : ["my_alias"]
}

however this does not work and no alias gets created. also I get no error.

thoughts?

-Amit.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Amit Soni) #5

Thanks David, my bad, I missed seeing that this is not closed.

-Amit.

On Thu, Nov 14, 2013 at 10:26 PM, David Pilato david@pilato.fr wrote:

You should have notice that this issue is not closed.
That means it's not available yet.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 15 novembre 2013 at 03:38:50, Amit Soni (amitsoni29@gmail.com//amitsoni29@gmail.com)
a écrit:

yes exactly.

David - Since it is not working for me yet, does the ordering matter?

-Amit.

On Thu, Nov 14, 2013 at 9:59 AM, David Pilato david@pilato.fr wrote:

I think you are looking for this:
https://github.com/elasticsearch/elasticsearch/issues/1695

 --

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 14 novembre 2013 at 18:54:25, Amit Soni (amitsoni29@gmail.com//amitsoni29@gmail.com)
a écrit:

Hi everyone - Would you know the command which would enable me to
create the index while I am creating settings and mapping?

Here is what I am executing:

{
"settings": {
...............
},
"mappings": {
....
},
"aliases" : ["my_alias"]
}

however this does not work and no alias gets created. also I get no error.

thoughts?

-Amit.

You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Guozhu Wei) #6

Thanks!

I changed the code to test the Qos and build the plugin, now the Qos works
and nothing lost now.

private class Consumer implements Runnable {



    private Connection connection;



    private Channel channel;



    @Override

    public void run() {

        while (true) {

            if (closed) {

                break;

            }

            try {

                connection =

connectionFactory.newConnection(rabbitAddresses);

                channel = connection.createChannel();

                channel.basicQos(200);

I didn’t dig into the code, but I think if the indexer raise an exception,
the river should not ack the message.

Thank you for your response!

发件人: elasticsearch@googlegroups.com
[mailto:elasticsearch@googlegroups.com] 代表 David Pilato
发送时间: 2013年11月15日 14:26
收件人: elasticsearch@googlegroups.com; Amit Soni
主题: Re: Including alias creation command while creating setting and
mapping

You should have notice that this issue is not closed.

That means it's not available yet.

--

David Pilato | Technical Advocate | Elasticsearch.com

https://twitter.com/dadoonet @dadoonet |
https://twitter.com/elasticsearchfr @elasticsearchfr

Le 15 novembre 2013 at 03:38:50, Amit Soni (amitsoni29@gmail.com
mailto://amitsoni29@gmail.com ) a écrit:

yes exactly.

David - Since it is not working for me yet, does the ordering matter?

-Amit.

On Thu, Nov 14, 2013 at 9:59 AM, David Pilato <david@pilato.fr
mailto:david@pilato.fr > wrote:

I think you are looking for this:

--

David Pilato | Technical Advocate | Elasticsearch.com

https://twitter.com/dadoonet @dadoonet |
https://twitter.com/elasticsearchfr @elasticsearchfr

Le 14 novembre 2013 at 18:54:25, Amit Soni (amitsoni29@gmail.com
mailto://amitsoni29@gmail.com ) a écrit:

Hi everyone - Would you know the command which would enable me to create the
index while I am creating settings and mapping?

Here is what I am executing:

{
"settings": {
...............
},
"mappings": {
....
},
"aliases" : ["my_alias"]
}

however this does not work and no alias gets created. also I get no error.

thoughts?

-Amit.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com
mailto:elasticsearch%2Bunsubscribe@googlegroups.com .
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com
mailto:elasticsearch%2Bunsubscribe@googlegroups.com .
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com
mailto:elasticsearch+unsubscribe@googlegroups.com .
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com
mailto:elasticsearch+unsubscribe@googlegroups.com .
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #7