Inconsistent search results

Hi,

I'm testing with a single index with replication and auto mapping creation
turned off. Strangely, I'm getting different no. of results for a single
query without any new insertions. I'm not able to reproduce this
consistently and this problem comes once or twice a week.

Any ideas what might be wrong?

Thanks,
Annad

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Hey,

what do you mean with "results for single query without new insertions"
exactly? You were talking about one index, but not about one shard, or?
(Always correct me, I am simply assuming stuff which is not mentioned). So
is it possible, that your query results differ, when you are inserting the
same data and then try the query?

If this is the issue, you could test either, if this problems happens, when
all your data is in one shard only as well or take a look at the
dfs_query_and_fetch search type option, see
http://www.elasticsearch.org/guide/reference/api/search/search-type/

If the both options above do not solve your problem, can you provide any
more information? Kind of queries, etc?

--Alex

On Wed, Jun 12, 2013 at 6:32 PM, anand nalya anand.nalya@gmail.com wrote:

Hi,

I'm testing with a single index with replication and auto mapping creation
turned off. Strangely, I'm getting different no. of results for a single
query without any new insertions. I'm not able to reproduce this
consistently and this problem comes once or twice a week.

Any ideas what might be wrong?

Thanks,
Annad

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.