Index level setting is not working for the merge factory and concurrency paramater


(JAYALAKSHMI R) #1

Hi All,

We have installed the 2.4.5 and 5.5.0 cluster in one environment and currently we are moving the data from 2.4.5 to 5.5.0 cluster using logstash. For making the indexing speed we have enabled the following factor in ES 5.5.0. But it is not working we are getting the below error:

Error:
{"error":{"root_cause":[{"type":"illegal_argument_exception","reason":"unknown setting [index.index.index_concurrency]
please check that any required plugins are installed, or check the breaking changes documentation for removed settings"}],
"type":"illegal_argument_exception",
"reason":"unknown setting [index.index.merge.policy.merge_factor] please check that any required plugins are installed,
or check the breaking changes documentation for removed settings"},"status":400}
"type":"illegal_argument_exception","reason":"unknown setting [index.indices.memory.index_buffer_size] please check that any required plugins are installed,
or check the breaking changes documentation for removed settings"},"status":400}

Index Settings:

curl -XPUT 'http://localhost:9204/_cluster/settings' -d '{
"transient" : {
"index_concurrency" : 32
"index.merge.policy.merge_factor" : 30
"indices.memory.index_buffer_size" : "80%"
}
}'

Note: we are doing these index setting after closing the all index


(JAYALAKSHMI R) #2

Hi,

Whether these settings depreciated in 5.5? If so please provide the new settings to configure the same.


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.