Index management : change index name in filebeat

hello,

I try to change the index name in filebeat.yml but when I start the filebeat, it still running on the oldest conf :

filebeat.yml :
output.elasticsearch:
hosts: ["xx.xx.xx.xx:9200"]
#index: "filebeat-%{[agent.version]}-%{+yyyy.MM.dd}"
index: "network-%{+yyyy.MM.dd}"

setup.template.settings:
index.number_of_shards: 1
setup.template.enabled: true
setup.template.name: "network"
setup.template.pattern: "network-*"

here, the log :
Set output.elasticsearch.index to 'filebeat-7.3.0' as ILM is enabled.

Only I think in the indentation of the text...

Coz ILM is enable. you need to add 'setup.ilm.enabled: false' to your filebeat.yml

hello,
it's works when setup.ilm.enabled is false !

Thanks

I will try it.

Good tip, thanks.

What if doesn't work?