Template configuration not working with ilm enabled


When I modify the "Elasticsearch template setting" part in the filebeat.yml file with the ilm enabled (by default), I can't manage to modify the index pattern of the template and it's name. The only thing that can be changed is the number of allocated shard.

However, when I explicitly disable the ilm in the filebeat.yml configuration file (setup.ilm.enabled: no), everything works as intended.

How can I manage to change the template index pattern with ilm enabled?

Thanks !

Hi @4rakasi :slightly_smiling_face:

Did you check specific ILM instructions for Filebeat here? https://www.elastic.co/guide/en/beats/filebeat/current/ilm.html

Remember that you won't create an index per day in Filebeat if ILM is setup. Index policies are now handled by ILM so you don't need to worry about this.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.