Index Missing : illegal Argument exception

Hi All,

I configured elastic search to use search and visualize the hadoop log
files.
I have hadoop cluster with 8 nodes and i use eco systems Hive/Pig to push
the log files to elastic search.
I configured elastic search successfully(single node) and i started kibana
as well.
When i try to run a sample Hive scripts which was given in elastic search
site. iam getting the following error.

hive> select * from artists;
OK
Failed with exception java.io.IOException:java.lang.IllegalException:Index
[radio/artists] missing and settings [es.field.read.empty.as.null] is set
to false
Time taken 0.348 seconds
hive>

Can somebody help me to fix this issue?

Many thanks in advance!

Regards,
Muthu

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/e4b6c528-e638-4cb5-b346-4c571031e997%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hi,

Can someone help me to fix this issue.
Many thanks in advance!

Regards,
Muthu

On Friday, September 12, 2014 11:27:03 PM UTC+5:30, Muthu Kumar wrote:

Hi All,

I configured elastic search to use search and visualize the hadoop log
files.
I have hadoop cluster with 8 nodes and i use eco systems Hive/Pig to push
the log files to elastic search.
I configured elastic search successfully(single node) and i started kibana
as well.
When i try to run a sample Hive scripts which was given in elastic search
site. iam getting the following error.

hive> select * from artists;
OK
Failed with exception java.io.IOException:java.lang.IllegalException:Index
[radio/artists] missing and settings [es.field.read.empty.as.null] is set
to false
Time taken 0.348 seconds
hive>

Can somebody help me to fix this issue?

Many thanks in advance!

Regards,
Muthu

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/b74e3423-5e98-4609-bdb5-5b9b3d7ceabe%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.