Index:no being ignore


(gchen) #1

Hi,

I have a field with index option set to 'no', but ES is ignoring that option.

I updated my doc-type with :
-XPUT my_index/_mapping/my_doc_type

{
    "properties": {
        "original_data": {
            "type": "object",
            "index": "no"
        }
    }
}

However when i check the mapping, the following was returned by ES:

{
    "original_data" : {
          "type" : "object"
    }
}

Why is ES ignoring the index option?

original_data is an nested object field, and i want ES to ignore this field and don't store it at all. The field could be different for different docs, which is one of the reason why i want ES to ignore it. What's the proper way to achieve that?

Just want to mention that i'm on version 1.7, i know it's old, we're working on migrating to the newer versions.

Thanks,
GC


(gchen) #2

Ok. i got it to work by setting 'enabled': false, but a little confused.

{
        "original_data": {
            "type": "object",
            "index": "no",
            "enabled": false
        }
}

So... does this means that index:no only controls the indexing part? Without enabled:false, ES would still parse the json and try to add it to the mapping?


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.