Index of field lost during update the document


(Ankit Jain) #1

Hi All,

We want to update an record into ES without enabling _source field.
*
For example:* Let as consider, an document contains four fields ( {col1(store=true,index=true)}, {
col2 (store=false, index=true)}, {col3 (store=true,index=true)}, {col4(store=true, index=true)} ). while updation, we would like to update only
value of col3 and keep store and index of rest of fields unchanged.

Issue: While updating the value of col3, the index of col2 got lost
because the value of col2 is only indexed in ElasticSearch.

Regards,
Ankit Jain

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Alexander Reelsen) #2

Hey,

please see the documentation at
http://www.elasticsearch.org/guide/reference/api/update/
'The _source field need to be enabled for this feature to work.'

So you will have to use the source field.

--Alex

On Tue, Sep 24, 2013 at 1:25 PM, Ankit Jain ankitjaincs06@gmail.com wrote:

Hi All,

We want to update an record into ES without enabling _source field.
*
For example:* Let as consider, an document contains four fields ( {col1(store=true,index=true)}, {
col2 (store=false, index=true)}, {col3 (store=true,index=true)}, {*
col4* (store=true, index=true)} ). while updation, we would like to
update only value of col3 and keep store and index of rest of fields
unchanged.

Issue: While updating the value of col3, the index of col2 got lost
because the value of col2 is only indexed in ElasticSearch.

Regards,
Ankit Jain

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Ankit Jain) #3

Thanks Alexander..

But, we are not storing the value of few fields and only indexing them into
ES. So, is it possible to maintain the index of those fields during update
call?

Regards,
Ankit Jain

On Friday, 27 September 2013 02:21:56 UTC+5:30, Alexander Reelsen wrote:

Hey,

please see the documentation at
http://www.elasticsearch.org/guide/reference/api/update/
'The _source field need to be enabled for this feature to work.'

So you will have to use the source field.

--Alex

On Tue, Sep 24, 2013 at 1:25 PM, Ankit Jain <ankitj...@gmail.com<javascript:>

wrote:

Hi All,

We want to update an record into ES without enabling _source field.
*
For example:* Let as consider, an document contains four fields ( {col1(store=true,index=true)}, {
col2 (store=false, index=true)}, {col3 (store=true,index=true)}, {*
col4* (store=true, index=true)} ). while updation, we would like to
update only value of col3 and keep store and index of rest of fields
unchanged.

Issue: While updating the value of col3, the index of col2 got
lost because the value of col2 is only indexed in ElasticSearch.

Regards,
Ankit Jain

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #4