Index pattern - circuit break and cannot read property of null

Hello , I have documented API's which include which tags they belong to, their request and response parameters, description, hostname.
each API goes up to 2000+ lines and up to date, I have pushed approximately 200 such files in .json format.

All the files have been indexed on the localhost.
the OS I'm using is Windows 10 and the Kibana version is 7.1.0.

I have indexed the APIs on the basis of tags. If an API is to be used for finance, it's indexed under api_finance index, similarly, if some API is used for transport its indexed in api_transport.

However, when I try to create an index pattern api*, Kibana seems to be loading for error and display

  1. Circuit breaking error which disconnects the kibana server on the command prompt window. It reconnects and disconnects and keeps on repeating the same error.
  2. cannot read property 'message' of null on the kibana browser window

I have tried using aliases by assigning "demo" as an alias for all the indices and then tried
creating the index pattern.
index pattern creates when I trying it with 10 files only but the error appears when I try with the whole documentation of 200 files.

Can someone please help me out?

Do these indices have the same mapping fields? If not, it's possible the index pattern being created is exceeding practical limits for the number of fields.

What do your mappings look like? If you're using any array fields, Elasticsearch may be handling these in ways that you may not expect that leads to a large number of unique mapping fields. Any more context here on the mappings would help me give more concrete advice :slight_smile:

The mappings for each index differs slightly.
I earlier got an error for limit for number of lines which I resolved by increasing the limit for the index.

PUT index_name/_settings

I will attach images of the mapping for 2 different indices.

cloud index mapping

article index

Thank you

Ok let's dig into the weeds a bit.

Can you post the response details for the request to /api/index_patterns/_fields_for_wildcard from the Developer Tools "Network" tab in your web browser?

This should help us figure out why the response isn't what is expected.

the output shows that the mapping is larger than 10Mb

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.