Index status going to RED After I create index with this setting "index.routing.allocation.require.box_type": "hot"

(Chandukreddi) #1

Hello Team,

I have 2 node cluster and one node is HOT and another node WARM.

Help me to understand why index status changing to RED when I use setting "index.routing.allocation.require.box_type": "hot"

Index creation script:

PUT /%3Cswift-proxy-logs-%7Bnow%2Fd%7D-1%3E
{
"settings": {
"number_of_replicas": 0,
"index.routing.allocation.require.box_type":"hot"
},
"aliases": {
"swift_proxy_log_write_alias": {
"is_write_index": true
}
}
}

[2019-05-10T08:14:30,630][INFO ][o.e.c.m.MetaDataCreateIndexService] [elk-1] [swift-proxy-logs-2019.05.10-1] creating index, cause [api], templates , shards [5]/[0], mappings
[2019-05-10T08:14:30,633][INFO ][o.e.c.r.a.AllocationService] [elk-1] Cluster health status changed from [YELLOW] to [RED] (reason: [index [swift-proxy-logs-2019.05.10-1] created]).

with out setting "index.routing.allocation.require.box_type": "hot" it works perfect.

PUT /%3Cswift-proxy-logs-%7Bnow%2Fd%7D-1%3E
{
"settings": {
"number_of_replicas": 0
},
"aliases": {
"swift_proxy_log_write_alias": {
"is_write_index": true
}
}
}

[2019-05-10T08:17:04,201][INFO ][o.e.c.m.MetaDataCreateIndexService] [elk-1] [swift-proxy-logs-2019.05.10-1] creating index, cause [api], templates , shards [5]/[0], mappings
[2019-05-10T08:17:04,345][INFO ][o.e.c.r.a.AllocationService] [elk-1] Cluster health status changed from [YELLOW] to [GREEN] (reason: [shards started [[swift-proxy-logs-2019.05.10-1][1], [swift-proxy-logs-2019.05.10-1][4], [swift-proxy-logs-2019.05.10-1][2], [swift-proxy-logs-2019.05.10-1][0]] ...]).

I really appreciate your help!

Thanks
Chandra

(Christian Dahlqvist) #2

Do you have an attribute named box_type set to hot in your Elasticsearch configuration? This post indicates the attribute may be named data and not box_type.

(Chandukreddi) #3

@Christian_Dahlqvist, your right I have attribute data not box_type.

Is this static or dynamic parameter? Can I change now?

 "name" : "elk-1",
  "transport_address" : "10.1.28.175:9300",
  "host" : "10.1.28.175",
  "ip" : "10.1.28.175",
  "version" : "6.7.1",
  "build_flavor" : "oss",
  "build_type" : "tar",
  "build_hash" : "2f32220",
  "total_indexing_buffer" : 421645516,
  "roles" : [
    "master",
    "data",
    "ingest"
  ],
  "attributes" : {
    "data" : "hot"
  },
  "settings" : {
    "cluster" : {
      "name" : "elk-test"
    },
    "node" : {
      "attr" : {
        "data" : "hot"
      },
      "name" : "elk-1"
    },
    "path" : {
      "data" : [
        "/opt/data/elastic",
        "/home/elk/opt1/data/elastic_1"
      ],
      "logs" : "/opt/data/logs/elastic",
      "home" : "/opt/elasticsearch"

Thanks
Chandra

(Christian Dahlqvist) #4

Why not change box_type to data in your template?

"index.routing.allocation.require.data":"hot"
(Chandukreddi) #5

I can do that.. will let you know once I made that change.

Thanks
Chandra