Index template file is not applied


#1

Hi all,
I configuring docker container with ES v2. I use next template:

{
  "template": "*",
  "order": 10,
  "settings": {},
  "mappings": {
    "_default_": {
      "dynamic_templates": [
        {
          "string_fields": {
            "match": "*",
            "match_mapping_type": "string",
            "mapping": {
              "index": "not_analyzed",
              "type": "string"
            }
          }
        }
      ]
    }
  }
}

If I put it via HTTP request - it works fine:

[2015-11-07 23:01:06,924][INFO ][cluster.metadata         ] [elastic-node] [jpolli-events-2015-11-07] creating index, cause [auto(index api)], templates [template_1], shards [5]/[1], mappings [_default_, storage_client_delete]

but if I place it in config/template path it doesn't applied:

[2015-11-07 23:02:13,915][INFO ][cluster.metadata         ] [elastic-node] [jpolli-events-2015-11-07] creating index, cause [auto(index api)], templates [], shards [5]/[1], mappings [http_response]

I have specified config path:

path.conf : "/usr/share/elasticsearch/config/"

and place template to /usr/share/elasticsearch/config/templates dir but it doesn't work. Order modification also doesn't help.

Any ideas what's wrong?


(Magnus B├Ąck) #2

I believe 2.0 dropped support for having index templates in files. The 2.0 index template documentation no longer lists this option and the 2.0 breaking changes documentation indicates the same thing (but is perhaps no 100% clear).


#3

Thanks Magnus,

Yes it's not clear from changelog but I'm afraid that it is the reason of issue. It raises another question of default configuration for docker but I'll create a separate topic


(system) #4