Indexer failures - ES rejected execution exception

Hi,
I am continuously getting Indexer failures errors on my Graylog web-UI console. This is the error:

{"type":"es_rejected_execution_exception","reason":"rejected execution of processing of [1574940][indices:data/write/bulk[s][p]]: request: BulkShardRequest [[graylog_51][0]] containing [1253] requests, target allocation id: ThoaIwTATn2Qy-FChUg69w, primary term: 1 on EsThreadPoolExecutor[name = HXyEMKD/write, queue capacity = 200, org.elasticsearch.common.util.concurrent.EsThreadPoolExecutor@73398a43[Running, pool size = 8, active threads = 8, queued tasks = 200, completed tasks = 934971]]"}

Already viewed the same topics in the forum but nothing helped.

I have increased the ES resource as well but still getting the same error.
Current Resources for ES Cluster:

ES Master Nodes - 4 Core CPU
ES Master Nodes - 16 Core CPU

Help needed! A quick response will be appreciated.

Thanks

If you are still getting them, then your cluster is still under resourced.
What version are you running?

Hi, @warkolm I am using ES version 6.8
Graylog - 3.3.2

Do you have Monitoring enabled? What does it show when you get these sorts of errors?

I haven't enabled Monitoring yet but planning to do it later.
Due to these plenty of index failures:
Do I loose the logs or they are getting still written to Elasticsearch?

Elasticsearch does not accept them, I don't know what Graylog does with that response though.

@warkolm
Also, I just want to know are the logs will be completed ignored by ES or it will be re-tried until written to the disk?

My previous answer is the only one I can give again there.

Elasticsearch will return an error. What happens after that depends on how Graylog handles those errors, which is not something we can answer here.

hmm
Thanks @warkolm @Christian_Dahlqvist

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.