Indexes solely on disk?

I'm running ElasticSearch on my local machine and I notice that every time
I restart my computer it places the index in a recovery mode and begins
reindexing the index. Looking at the data directory the index is store
there so why is it labeled as recovering and reindexing? Is there a way so
that this does not happen?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Hi,

the chance is that the data is in fact not in Lucene segment but in
transaction log so ES has to replay it first. Can you check size of
transaction log?

Regards,
Lukas

On Fri, Jun 28, 2013 at 2:31 AM, Matt Arkin arkin@endlessm.com wrote:

I'm running ElasticSearch on my local machine and I notice that every time
I restart my computer it places the index in a recovery mode and begins
reindexing the index. Looking at the data directory the index is store
there so why is it labeled as recovering and reindexing? Is there a way so
that this does not happen?

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Hi Lukas,

Sorry for the delay, I'm just getting back on this issue. I don't seem to
have this issue any more, though now the transaction log is empty.

Now I'm trying to copy indexes from one machine to the other, and it would
be awesome if I could do this without the index entering a recovery mode. I
thought I could just copy the index from one machine to another by copy
/nodes/0/indices/[index] folder, but when I start elasticsearch back up on
the receiving computer its in a recovering mode:

  • shards: {
    • 2: [
      • {
        • routing: {
          • state: INITIALIZING
          • primary: true
          • node: rgqLc53PTQSFmIBpr0Wa8w
          • relocating_node: null
          • shard: 2
          • index: pthtml
            }
        • state: RECOVERING
        • index: {
          • size: 157.1mb
          • size_in_bytes: 164736056
            }
            }
            ]
    • 4: [
      • {
        • routing: {
          • state: INITIALIZING
          • primary: true
          • node: rgqLc53PTQSFmIBpr0Wa8w
          • relocating_node: null
          • shard: 4
          • index: pthtml
            }
        • state: RECOVERING
        • index: {
          • size: 154.9mb
          • size_in_bytes: 162513626
            }
            }
            ]
            }

On Thursday, June 27, 2013 10:37:09 PM UTC-7, Lukáš Vlček wrote:

Hi,

the chance is that the data is in fact not in Lucene segment but in
transaction log so ES has to replay it first. Can you check size of
transaction log?

Regards,
Lukas

On Fri, Jun 28, 2013 at 2:31 AM, Matt Arkin <ar...@endlessm.com<javascript:>

wrote:

I'm running ElasticSearch on my local machine and I notice that every
time I restart my computer it places the index in a recovery mode and
begins reindexing the index. Looking at the data directory the index is
store there so why is it labeled as recovering and reindexing? Is there a
way so that this does not happen?

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.