Initial Latency problem


(Mário Rodrigues) #1

I'm using ES to provide an autocomplete search and, sometimes, the search can take up to 10 seconds but then it's really fluid.

I took a look at my application monitor and found that the problem is the ES response time:

I'm using a single node "cluster" with 1 Gb and it only has around 2 megabytes worth of data.

What can I do to fix this problem?


(André Hänsel) #2

Does this occur after a period of not using it? Might have been swapped out. Do you have swap enabled? See also: https://www.elastic.co/guide/en/elasticsearch/reference/current/setup-configuration.html


(Christian Dahlqvist) #3

How do you perform your autocomplete search? Are you using edge ngrams?


(Mário Rodrigues) #4

I'm using a filtered query and I'm not using edge grams or anything that could justify the performance penalty. I've the same setup on another project and I don't have this problem at all. I'm using version 1.7 and I don't if the recent found.no migration could explain this.


(system) #5