Input plugin 'file' issue


(abhiage) #1

I want to push tomcat logs into elastic search

My config file is

input {
stdin {
type => "stdin-type"
}

file {
type => "weblog"

# Wildcards work, here :)
path => D:\tomcatlog.log

}
}

output {
stdout { }
elasticsearch { embedded => true }
}

When i run logstash it shows following message and no logs are getting in
elastic search

←[33mUsing milestone 2 input plugin 'file'. This plugin should be stable,
but if
you see strange behavior, please let us know! For more information on
plugin mi
lestones, see http://logstash.net/docs/1.2.2/plugin-milestones
{:level=>:warn}←[
0m

Any solution to above problem?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #2

Just wondering if you should not double backslash chars:
path => D:\tomcatlog.log
Or something similar?

Does it help?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 21 novembre 2013 at 06:56:20, abhi patel (abhiage@gmail.com) a écrit:

I want to push tomcat logs into elastic search
My config file is

input {
stdin {
type => "stdin-type"
}

file {
type => "weblog"

# Wildcards work, here :)
path => D:\tomcatlog.log

}
}

output {
stdout { }
elasticsearch { embedded => true }
}
When i run logstash it shows following message and no logs are getting in elastic search
←[33mUsing milestone 2 input plugin 'file'. This plugin should be stable, but if
you see strange behavior, please let us know! For more information on plugin mi
lestones, see http://logstash.net/docs/1.2.2/plugin-milestones {:level=>:warn}←[
0m
Any solution to above problem?

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(abhiage) #3

I guess its not an error its just a warning regarding plugin mile stone.

I think path syntax is the concern.is it?

On Thursday, November 21, 2013 1:59:29 PM UTC+5:30, David Pilato wrote:

Just wondering if you should not double backslash chars:

path => D:\tomcatlog.log

Or something similar?

Does it help?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 21 novembre 2013 at 06:56:20, abhi patel (abh...@gmail.com<javascript:>)
a écrit:

I want to push tomcat logs into elastic search

My config file is

input {
stdin {
type => "stdin-type"
}

file {
type => "weblog"

# Wildcards work, here :)
path => D:\tomcatlog.log

}
}

output {
stdout { }
elasticsearch { embedded => true }
}

When i run logstash it shows following message and no logs are getting in
elastic search

←[33mUsing milestone 2 input plugin 'file'. This plugin should be stable,
but if
you see strange behavior, please let us know! For more information on
plugin mi
lestones, see http://logstash.net/docs/1.2.2/plugin-milestones
{:level=>:warn}←[
0m

Any solution to above problem?

You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(abhiage) #4

I have tried what you suggested but it is showing error that only absolute
path should be mentioned.

On Thursday, November 21, 2013 1:59:29 PM UTC+5:30, David Pilato wrote:

Just wondering if you should not double backslash chars:

path => D:\tomcatlog.log

Or something similar?

Does it help?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 21 novembre 2013 at 06:56:20, abhi patel (abh...@gmail.com<javascript:>)
a écrit:

I want to push tomcat logs into elastic search

My config file is

input {
stdin {
type => "stdin-type"
}

file {
type => "weblog"

# Wildcards work, here :)
path => D:\tomcatlog.log

}
}

output {
stdout { }
elasticsearch { embedded => true }
}

When i run logstash it shows following message and no logs are getting in
elastic search

←[33mUsing milestone 2 input plugin 'file'. This plugin should be stable,
but if
you see strange behavior, please let us know! For more information on
plugin mi
lestones, see http://logstash.net/docs/1.2.2/plugin-milestones
{:level=>:warn}←[
0m

Any solution to above problem?

You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #5

Try with d:/tomcatlog.log

I guess it should work.

Le 21 novembre 2013 à 12:46, abhi patel abhiage@gmail.com a écrit :

I have tried what you suggested but it is showing error that only absolute
path should be mentioned.

On Thursday, November 21, 2013 1:59:29 PM UTC+5:30, David Pilato wrote:

Just wondering if you should not double backslash chars:

   > > > 
      path => D:\\tomcatlog.log

Or something similar?

Does it help?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfr
https://twitter.com/elasticsearchfr

Le 21 novembre 2013 at 06:56:20, abhi patel (abh...@gmail.com) a écrit:

   > > > 
   I want to push tomcat logs into elastic search

   My config file is

      input {
        stdin {
          type => "stdin-type"
        }

        file {
          type => "weblog"

          # Wildcards work, here :)
          path => D:\tomcatlog.log
        }
      }

      output {
        stdout { }
        elasticsearch { embedded => true }
      }

   When i run logstash it shows following message and no logs are

getting in elastic search

   ←[33mUsing milestone 2 input plugin 'file'. This plugin should be

stable, but if
you see strange behavior, please let us know! For more information
on plugin mi
lestones, see http://logstash.net/docs/1.2.2/plugin-milestones
{:level=>:warn}←[
0m

   Any solution to above problem?
   --
   You received this message because you are subscribed to the Google

Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to elasticsearc...@googlegroups.com.
For more options, visithttps://groups.google.com/groups/opt_out .

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visithttps://groups.google.com/groups/opt_out .

--
David Pilato
http://www.scrutmydocs.org/
http://dev.david.pilato.fr/
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Andrej) #6

First, you could set start_position to beginning, by default its end and
you will only see logs new in the file. Second, you should look out for the
.sinceDB file (remove it or set it to something like /dev/null), otherwise
logstash remebers the last position in the file and will not reprocess it
again.

Greets,
Andrej

Am Donnerstag, 21. November 2013 12:46:34 UTC+1 schrieb abhi patel:

I have tried what you suggested but it is showing error that only absolute
path should be mentioned.

On Thursday, November 21, 2013 1:59:29 PM UTC+5:30, David Pilato wrote:

Just wondering if you should not double backslash chars:

path => D:\tomcatlog.log

Or something similar?

Does it help?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 21 novembre 2013 at 06:56:20, abhi patel (abh...@gmail.com) a écrit:

I want to push tomcat logs into elastic search

My config file is

input {
stdin {
type => "stdin-type"
}

file {
type => "weblog"

# Wildcards work, here :)
path => D:\tomcatlog.log

}
}

output {
stdout { }
elasticsearch { embedded => true }
}

When i run logstash it shows following message and no logs are getting
in elastic search

←[33mUsing milestone 2 input plugin 'file'. This plugin should be stable,
but if
you see strange behavior, please let us know! For more information on
plugin mi
lestones, see http://logstash.net/docs/1.2.2/plugin-milestones
{:level=>:warn}←[
0m

Any solution to above problem?

You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #7