Install Elasticsearch 5.6 on a new port


(CJ AI) #1

Hi,

SugarCRM recommends to install Elasticsearch 5.4 or 5.6 on a new port in order to allow the upgrade to the next platform.
For years they've recommended 1.7.5 which I currently have and now in order to do the transition to Elasticsearch 5.6 they recommend to install the new version on a new port.

They don't have any documentation for this installation and as far as I can see from some discussions in here, is not quite recommended to do that!
I did logged a call with their Support but...they're not the fastest or best in that area...will leave it there for now.

Can anyone help with this transition from 1.7.5 to 5.6 for RHEL7; I prefer to use yum and .rpm packages.

I tried on a different test server ( with ver 5.6 only) to change the ports by modifying the elasticsearch.yml file and it worked but on my Main Server I have version 1.7.5 and not sure how to install on a different path; tried with -Epath /path/to/installation but it didn't work.

My install for 1.7.5 was something like this:

wget -P /tmp https://download.elastic.co/elasticsearch/elasticsearch/elasticsearch-1.7.5.noarch.rpm
yum -y install /tmp/elasticsearch*.rpm

systemctl daemon-reload
systemctl enable elasticsearch.service
systemctl start elasticsearch.service

verify version
/usr/share/elasticsearch/bin/elasticsearch -v

check elastic search:
curl -X GET 'http://localhost:9200'

Any help would be appreciated.


(CJ AI) #2

anyone? :smiley:


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.