Install Head Plugin on Client Node


(Clinton Blackburn) #1

Pasted from https://github.com/mobz/elasticsearch-head/issues/84.

I have a cluster with one data node and one client node. The plugin
installs properly on the data node, but not the client node. As you can see
below the install ostensibly succeeds; however, the site directory is not
created. Visiting http://localhost:9200/plugin/head results in a 301 with
curl and a 404 in the browser.

Is this a known issue with plugins on client nodes?

[xxx@yyy plugins]$ sudo /usr/share/elasticsearch/bin/plugin -v --install
mobz/elasticsearch-head
-> Installing mobz/elasticsearch-head...
Trying https://github.com/mobz/elasticsearch-head/archive/master.zip...
Downloading ........................DONE
Installed mobz/elasticsearch-head into /usr/share/elasticsearch/plugins/head
Identified as a _site plugin, moving to _site structure ...
Installed mobz/elasticsearch-head into /usr/share/elasticsearch/plugins/head
/_site

[xxx@yyy plugins]$ ls -al head/
dist/ index.html
README.textile
elasticsearch-head.sublime-project .jshintrc src/
.gitignore LICENCE test
/
Gruntfile.js package.json

[xxx@yyy plugins]$ curl -v http://localhost:9200/_plugin/head

  • About to connect() to localhost port 9200 (#0)
  • Trying 127.0.0.1...
  • Connected to localhost (127.0.0.1) port 9200 (#0)

GET /_plugin/head HTTP/1.1
User-Agent: curl/7.29.0
Host: localhost:9200
Accept: /

< HTTP/1.1 301 Moved Permanently
< Content-Type: text/html
< Access-Control-Allow-Origin: *
< Content-Length: 72
< Server: Jetty(8.1.4.v20120524)
<

  • Connection #0 to host localhost left intact

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #2

Try http://localhost:9200/_plugin/head/
(Look at the / at the end)

David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 5 oct. 2013 à 06:44, Clinton Blackburn clinton.blackburn@gmail.com a écrit :

Pasted from https://github.com/mobz/elasticsearch-head/issues/84.

I have a cluster with one data node and one client node. The plugin installs properly on the data node, but not the client node. As you can see below the install ostensibly succeeds; however, the site directory is not created. Visiting http://localhost:9200/plugin/head results in a 301 with curl and a 404 in the browser.

Is this a known issue with plugins on client nodes?

[xxx@yyy plugins]$ sudo /usr/share/elasticsearch/bin/plugin -v --install mobz/elasticsearch-head
-> Installing mobz/elasticsearch-head...
Trying https://github.com/mobz/elasticsearch-head/archive/master.zip...
Downloading ........................DONE
Installed mobz/elasticsearch-head into /usr/share/elasticsearch/plugins/head
Identified as a _site plugin, moving to _site structure ...
Installed mobz/elasticsearch-head into /usr/share/elasticsearch/plugins/head/_site

[xxx@yyy plugins]$ ls -al head/
dist/ index.html README.textile
elasticsearch-head.sublime-project .jshintrc src/
.gitignore LICENCE test/
Gruntfile.js package.json

[xxx@yyy plugins]$ curl -v http://localhost:9200/_plugin/head

  • About to connect() to localhost port 9200 (#0)
  • Trying 127.0.0.1...
  • Connected to localhost (127.0.0.1) port 9200 (#0)

GET /_plugin/head HTTP/1.1
User-Agent: curl/7.29.0
Host: localhost:9200
Accept: /

< HTTP/1.1 301 Moved Permanently
< Content-Type: text/html
< Access-Control-Allow-Origin: *
< Content-Length: 72
< Server: Jetty(8.1.4.v20120524)
<

  • Connection #0 to host localhost left intact

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Clinton Blackburn) #3

http://dev-api.kyruus.com:9200/_plugin/head results in a 301 to
http://dev-api.kyruus.com:9200/_plugin/head/, which results in a 404. As I
mentioned, the installation doesn't seem to work properly. The
/usr/share/elasticsearch/plugins/head/_site directory is not created.
Instead all files are installed in /usr/share/elasticsearch/plugins/head/.

Thanks,
Clinton

On Sat, Oct 5, 2013 at 2:04 AM, David Pilato david@pilato.fr wrote:

Try http://localhost:9200/_plugin/head/
(Look at the / at the end)

David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 5 oct. 2013 à 06:44, Clinton Blackburn clinton.blackburn@gmail.com a
écrit :

Pasted from https://github.com/mobz/elasticsearch-head/issues/84.

I have a cluster with one data node and one client node. The plugin
installs properly on the data node, but not the client node. As you can see
below the install ostensibly succeeds; however, the site directory is not
created. Visiting http://localhost:9200/plugin/head results in a 301 with
curl and a 404 in the browser.

Is this a known issue with plugins on client nodes?

[xxx@yyy plugins]$ sudo /usr/share/elasticsearch/bin/plugin -v --install
mobz/elasticsearch-head
-> Installing mobz/elasticsearch-head...
Trying https://github.com/mobz/elasticsearch-head/archive/master.zip...
Downloading ........................DONE
Installed mobz/elasticsearch-head into /usr/share/elasticsearch/plugins/
head
Identified as a _site plugin, moving to _site structure ...
Installed mobz/elasticsearch-head into /usr/share/elasticsearch/plugins/
head/_site

[xxx@yyy plugins]$ ls -al head/
dist/ index.html
README.textile
elasticsearch-head.sublime-project .jshintrc
src/
.gitignore LICENCE
test/
Gruntfile.js package.json

[xxx@yyy plugins]$ curl -v http://localhost:9200/_plugin/head

  • About to connect() to localhost port 9200 (#0)
  • Trying 127.0.0.1...
  • Connected to localhost (127.0.0.1) port 9200 (#0)

GET /_plugin/head HTTP/1.1
User-Agent: curl/7.29.0
Host: localhost:9200
Accept: /

< HTTP/1.1 301 Moved Permanently
< Content-Type: text/html
< Access-Control-Allow-Origin: *
< Content-Length: 72
< Server: Jetty(8.1.4.v20120524)
<

  • Connection #0 to host localhost left intact

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/yEX7Xl2XHqY/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #4

Ha right. Are you using es 0.90.3 or 0.90.4?
If so, update to 0.90.5. I think plugin manager has been fixed recently.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 5 oct. 2013 à 15:50, Clinton Blackburn clinton.blackburn@gmail.com a écrit :

http://dev-api.kyruus.com:9200/_plugin/head results in a 301 to http://dev-api.kyruus.com:9200/_plugin/head/, which results in a 404. As I mentioned, the installation doesn't seem to work properly. The /usr/share/elasticsearch/plugins/head/_site directory is not created. Instead all files are installed in /usr/share/elasticsearch/plugins/head/.

Thanks,
Clinton

On Sat, Oct 5, 2013 at 2:04 AM, David Pilato david@pilato.fr wrote:

Try http://localhost:9200/_plugin/head/
(Look at the / at the end)

David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 5 oct. 2013 à 06:44, Clinton Blackburn clinton.blackburn@gmail.com a écrit :

Pasted from https://github.com/mobz/elasticsearch-head/issues/84.

I have a cluster with one data node and one client node. The plugin installs properly on the data node, but not the client node. As you can see below the install ostensibly succeeds; however, the site directory is not created. Visiting http://localhost:9200/plugin/head results in a 301 with curl and a 404 in the browser.

Is this a known issue with plugins on client nodes?

[xxx@yyy plugins]$ sudo /usr/share/elasticsearch/bin/plugin -v --install mobz/elasticsearch-head
-> Installing mobz/elasticsearch-head...
Trying https://github.com/mobz/elasticsearch-head/archive/master.zip...
Downloading ........................DONE
Installed mobz/elasticsearch-head into /usr/share/elasticsearch/plugins/head
Identified as a _site plugin, moving to _site structure ...
Installed mobz/elasticsearch-head into /usr/share/elasticsearch/plugins/head/_site

[xxx@yyy plugins]$ ls -al head/
dist/ index.html README.textile
elasticsearch-head.sublime-project .jshintrc src/
.gitignore LICENCE test/
Gruntfile.js package.json

[xxx@yyy plugins]$ curl -v http://localhost:9200/_plugin/head

  • About to connect() to localhost port 9200 (#0)
  • Trying 127.0.0.1...
  • Connected to localhost (127.0.0.1) port 9200 (#0)

GET /_plugin/head HTTP/1.1
User-Agent: curl/7.29.0
Host: localhost:9200
Accept: /

< HTTP/1.1 301 Moved Permanently
< Content-Type: text/html
< Access-Control-Allow-Origin: *
< Content-Length: 72
< Server: Jetty(8.1.4.v20120524)
<

  • Connection #0 to host localhost left intact

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/yEX7Xl2XHqY/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Clinton Blackburn) #5

Upgrading to 0.90.5 (from 0.90.4) resolved the issue. Thanks!

Clinton

On Sat, Oct 5, 2013 at 12:56 PM, David Pilato david@pilato.fr wrote:

Ha right. Are you using es 0.90.3 or 0.90.4?
If so, update to 0.90.5. I think plugin manager has been fixed recently.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 5 oct. 2013 à 15:50, Clinton Blackburn clinton.blackburn@gmail.com a
écrit :

http://dev-api.kyruus.com:9200/_plugin/head results in a 301 to
http://dev-api.kyruus.com:9200/_plugin/head/, which results in a 404. As
I mentioned, the installation doesn't seem to work properly. The
/usr/share/elasticsearch/plugins/head/_site directory is not created.
Instead all files are installed in /usr/share/elasticsearch/plugins/head/.

Thanks,
Clinton

On Sat, Oct 5, 2013 at 2:04 AM, David Pilato david@pilato.fr wrote:

Try http://localhost:9200/_plugin/head/
(Look at the / at the end)

David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 5 oct. 2013 à 06:44, Clinton Blackburn clinton.blackburn@gmail.com
a écrit :

Pasted from https://github.com/mobz/elasticsearch-head/issues/84.

I have a cluster with one data node and one client node. The plugin
installs properly on the data node, but not the client node. As you can see
below the install ostensibly succeeds; however, the site directory is not
created. Visiting http://localhost:9200/plugin/head results in a 301
with curl and a 404 in the browser.

Is this a known issue with plugins on client nodes?

[xxx@yyy plugins]$ sudo /usr/share/elasticsearch/bin/plugin -v --install
mobz/elasticsearch-head
-> Installing mobz/elasticsearch-head...
Trying https://github.com/mobz/elasticsearch-head/archive/master.zip...
Downloading ........................DONE
Installed mobz/elasticsearch-head into /usr/share/elasticsearch/plugins/
head
Identified as a _site plugin, moving to _site structure ...
Installed mobz/elasticsearch-head into /usr/share/elasticsearch/plugins/
head/_site

[xxx@yyy plugins]$ ls -al head/
dist/ index.html
README.textile
elasticsearch-head.sublime-project .jshintrc
src/
.gitignore LICENCE
test/
Gruntfile.js package.json

[xxx@yyy plugins]$ curl -v http://localhost:9200/_plugin/head

  • About to connect() to localhost port 9200 (#0)
  • Trying 127.0.0.1...
  • Connected to localhost (127.0.0.1) port 9200 (#0)

GET /_plugin/head HTTP/1.1
User-Agent: curl/7.29.0
Host: localhost:9200
Accept: /

< HTTP/1.1 301 Moved Permanently
< Content-Type: text/html
< Access-Control-Allow-Origin: *
< Content-Length: 72
< Server: Jetty(8.1.4.v20120524)
<

  • Connection #0 to host localhost left intact

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/yEX7Xl2XHqY/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/yEX7Xl2XHqY/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #6