Install Metricbeat on Kubernetes Cluster ( Azure)

Hi team,

i am trying for several weeks to install metricbeat on kubernetes cluster (azure) and i following these instructions:
Run Metricbeat on Kubernetes | Metricbeat Reference [8.6] | Elastic

i edited the metricbeat-kubernetes.yml file following
But the dashboard on kibana is showing nothing ......

- module: kubernetes
                  metricsets:
                    - apiserver
                  hosts: ["https://monitoringk8s-dns-8fba3240.hcp.northeurope.azmk8s.io:80"]

output.elasticsearch:
      #hosts: ['${ELASTICSEARCH_HOST:elasticsearch}:${ELASTICSEARCH_PORT:9200}']
      #username: ${ELASTICSEARCH_USERNAME}
      #password: ${ELASTICSEARCH_PASSWORD}
      
       hosts: [ "http://elasticsearch.imc-hosting.com:80"]
       username: "xxxxxxxxx"
       password: "xxxxxxxxxxxxxx"

@warkolm

i installed on VM :

  1. curl -L -O https://artifacts.elastic.co/downloads/beats/metricbeat/metricbeat-8.5.1-x86_64.rpm
  2. Edit the configuration -> Modify /etc/metricbeat/metricbeat.yml
  3. Enable and configure the kubernetes module
    4 .Start Metricbeat
  4. Module status
    Check that data is received from the Metricbeat kubernetes module
    Check data
    Data successfully received from this module

After this i went on the Dashboard and under Metricbeat Kubernetes Overwiev i can't see anything...

And i am getting this error:

Error encountered while loading saved dashboard: Could not locate that dashboard (id: AV4RGUqo5NkDleZmzKuZ-ecs)

Do i missed any configuration ?

In future please don't ping people that aren't already part of your topic.

Did you run the setup command? If not then that's the likely cause.

i am sorry okai .

yes i run the setup command.

Anything in the logs of Metricbeat? Also, not having any credentials when querying the Kubernetes API on a public interface sounds weird to me.

@xeraa
its working now.. the problem was the version of metricbeat. Using now 7.17. The latest one did not worked.

I just hide the credentials