Installation documentation 1.7 faulty


(mos) #1

Just installed elasticsearch 1.7.2 on windows.

Running:

elasticsearch.bat

works!

But

elasticsearch --cluster.name my_cluster_name

failed with

Unrecognized option: --cluster.name
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

It's copy and paste from the documentation at https://www.elastic.co/guide/en/elasticsearch/reference/current/_installation.html

It seems that the parameter is passed to the VM and not the elasticsearch. What's wrong? Documentation?


(Nik Everett) #2

Can you try

elasticsearch.bat --cluster.name my_cluster_name

?


(Nik Everett) #3

Er, or whatever it'd look like in windows.


(mos) #4

That's what I tried also. Didn't work either. I tried all possibilities. The only parameters that are working are --silent and -s which are directly processed in the elasticsearch.bat


(mos) #5

Anyone else using Windows 7?
It's a bummer if one of the first example commands in the installation documentation doesn't work ....


(Robbie Ogburn) #6

On windows try this:

elasticsearch.bat -Des.cluster.name my_cluster_name

Alternatively you can set the cluster.name the elasticsearch.yml file.

Cheers!


(mos) #7
-Des.cluster.name=my_cluster_name

works for me. Thanks.

Somebody needs to upade the elasticseach-docu.


(system) #8