Installed Elasticsearch 7.1.1 via MSI now What?


I am new to elasticsearch, I sort of just want to get up and running asap and see if this product will be right for me.

I installed the msi and then tried to run : http://localhost:9200/ but I get "The site cannot be reached".

I am on my personal windows 10 computer with just a basic firewall and such.

I can't even tell if elasticserach is runing.

When installing using the MSI,

  1. did you choose to install Elasticsearch as a service, and to start as part of installation
  2. did the installation end successfully?


I uninstalled then retried following this tutorial

now I get

PS C:\Program Files\Elastic\Elasticsearch\7.1.1\bin> .\elasticsearch
An exception occurred while trying to start elasticsearch.: System.UnauthorizedAccessException: Access to the path 'C:\Program Files\Elastic\Elasticsearch\7.1.1\logs' is denied.
   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.IO.Directory.InternalCreateDirectory(String fullPath, String path, Object dirSecurityObj, Boolean checkHost)
   at System.IO.Directory.InternalCreateDirectoryHelper(String path, Boolean checkHost)
   at System.IO.Abstractions.DirectoryWrapper.CreateDirectory(String path)
   at Elastic.ProcessHosts.Elasticsearch.Process.ElasticsearchProcess.Start()
   at Elastic.ProcessHosts.Service.Service.Run()
   at Elastic.ProcessHosts.Elasticsearch.Program.Main(String[] args)
Elasticsearch.exe does not have permission to write exception to event log

You need to have admin permissions to start elasticsearch, or the user with which you're starting elasticsearch must have access to C:\Program Files\Elastic\Elasticsearch\7.1.1\logs.

What parameters did you use to install Elasticsearch? Specifically, did you choose to install Elasticsearch as a service and if so, what credentials did you choose to run the service?


I followed this tutorial :

I did not set any credentials up but as per the tutorial I choose "do not install as service"

Can you try running Elasticsearch.exe as an administrator?

Ok I think that worked

  "name" : "DESKTOP-R4NR03R",
  "cluster_name" : "elasticsearch",
  "cluster_uuid" : "xYu5AJX-RgGq0tB9dF-HDA",
  "version" : {
    "number" : "7.1.1",
    "build_flavor" : "unknown",
    "build_type" : "unknown",
    "build_hash" : "7a013de",
    "build_date" : "2019-05-23T14:04:00.380842Z",
    "build_snapshot" : false,
    "lucene_version" : "8.0.0",
    "minimum_wire_compatibility_version" : "6.8.0",
    "minimum_index_compatibility_version" : "6.0.0-beta1"
  "tagline" : "You Know, for Search"

So everytime I want to use elastic serach I have to run that .exe as admin as I did not install it as a service correct?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.