Installing elasticsearch plugins with ansible


(Terrence Pugh) #1

I'm using ansible for elasticsearch ( ansible-elasticsearch) and need to install plugins from a url , local file, or alternative repo. is there a way I can reference a plugin by something other than just:
es_plugins: -plugin: elasticsearch/license version: latest


(Daniel Mitterdorfer) #2

Hi,

the same question seems to be answered on Stackoverflow already: http://stackoverflow.com/questions/39103926/install-elasticsearch-plugins-with-ansible

However, there is an open ticket to support plugin installation via URI so this does not work currently.

Daniel


(ganeshbabu) #3

Hi @danielmitterdorfer

Thanks for the link which you shared..

I tried to follow the same setup by giving the below lines as like this,

es_plugins:
  - plugin: https://github.com/royrusso/elasticsearch-HQ/zipball/master

Below is the response I am getting when I ran ansible-playbook standard.yml file

TASK [elasticsearch : Install elasticsearch plugins] ***************************
basic
[WARNING]: The loop variable 'item' is already in use. You should set the loop_var value in the loop_control option for the task to something else to
avoid variable collisions and unexpected behavior.

skipping: [localhost] => (item={u'plugin': u'https://github.com/royrusso/elasticsearch-HQ/zipball/master'})

Please let me know your thoughts.

Thanks,
Ganeshbabu R


(system) #4