Installing filebeats Ubuntu 16.04 repo timeout


(cristian) #1

When looking over the installation documentation for APT it is stated that you need to download and add the elasticsearch GPG key, and than add the following repo

deb https://artifacts.elastic.co/packages/5.x/apt stable main

Resource
https://www.elastic.co/guide/en/beats/filebeat/current/setup-repositories.html
https://www.elastic.co/guide/en/elasticsearch/reference/current/deb.html#deb-repo

Than run

apt-get update
apt-get install filebeat

The problem is that i get an connection timeout for the update command for the repo

Err:5 https://packages.elastic.co/beats/apt stable InRelease
Connection timed out after 120000 milliseconds

Anyone who can advice, are the repo broken or is their a fix?

Thanks in advance
Best regards.


(Andrew Kroh) #2

It should be connecting to https://artifacts.elastic.co/packages/5.x/apt when running update if you are using the 5.x repo. You should double check the sources you have configured.

https://packages.elastic.co/beats/apt is used to serve the 1.x beats releases. In any case I can confirm that both repos are still available (tested from Virginia, US). I tested the instructions for both 5.x and 1.x on an Ubuntu 17.04 machine.


(cristian) #3

Thank you for your reply andrewkroh!

I used the following command from the documentation page, step 3 under APT
echo "deb https://artifacts.elastic.co/packages/5.x/apt stable main" | sudo tee -a /etc/apt/sources.list.d/elastic-5.x.list

So when i run

cat /etc/apt/sources.list.d/elastic-5.x.list

i get

deb https://artifacts.elastic.co/packages/5.x/apt stable main

And the error i get is as follows

Err:5 https://packages.elastic.co/beats/apt stable InRelease
Connection timed out after 120000 milliseconds

Which you say is for the 1.x repo?


(Andrew Kroh) #4

Yes, https://packages.elastic.co/beats/apt is the location of the 1.x beats APT repo. And it is online so it should not be resulting in a connection time-out.

Can you please check to see what other sources you have configured.

cat /etc/apt/sources.list /etc/apt/sources.list.d/* | grep -v ^#


(cristian) #5

It is a very basic server installation, so not a whole lot is in sources lists

cat /etc/apt/sources.list /etc/apt/sources.list.d/* | grep -v ^#

deb http://dk.archive.ubuntu.com/ubuntu/ xenial main restricted
deb http://dk.archive.ubuntu.com/ubuntu/ xenial-updates main restricted
deb http://dk.archive.ubuntu.com/ubuntu/ xenial universe
deb http://dk.archive.ubuntu.com/ubuntu/ xenial-updates universe
deb http://dk.archive.ubuntu.com/ubuntu/ xenial multiverse
deb http://dk.archive.ubuntu.com/ubuntu/ xenial-updates multiverse
deb http://dk.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu xenial-security main restricted
deb http://security.ubuntu.com/ubuntu xenial-security universe
deb http://security.ubuntu.com/ubuntu xenial-security multiverse
deb https://artifacts.elastic.co/packages/5.x/apt stable main


(Andrew Kroh) #6

That looks to me. So I'm surprised you are seeing it even try to connect to https://packages.elastic.co/beats/apt.

Let's see if we can get someone else to try and reproduce the issue.


(Noémi Ványi) #7

Hi,

I tried to reproduce the issue on Debian 9 (Stretch) from Central Europe, but it works for me.


(cristian) #8

Is their anything that i can do about this?


(cristian) #9

My god this is unprofessional.

Even after contacting support no response what so ever.

If the products reflect the way you deal with problems, it cannot be very good overall.
Which so far results in an epic fail that even makes the products inaccessible, good job guys.


(Tudor Golubenco) #10

@drenriza I'm sorry for the bad experience. It seems like we cannot reproduce the timeout that you are seeing. Perhaps there's a firewall or router getting in the way?

I can't find your support ticket in our systems, can you email the ticket number to me, please? (tudor@elastic.co). I can check whether something went wrong on that side.


(Andrew Kroh) #11

Just to be absolutely sure the Filebeat APT instructions are working as expected I did another test. I used newly provisioned Ubuntu 16.04 from europe-west1-b (St. Ghislain, Belgium) on GCE. Filebeat installed without any timeouts.

The artifacts are served from AWS in us-east-1.

bash-3.2$ ssh gce-ubuntu-1604
The authenticity of host '104.155.xx.xx (104.155.xx.xx)' can't be established.
ECDSA key fingerprint is SHA256:83KvxJHMT0u23EqeAfq/RMJsBWlO58MjP85Qe3Ue9ZM.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '104.155.xx.xx' (ECDSA) to the list of known hosts.
Welcome to Ubuntu 16.04.3 LTS (GNU/Linux 4.10.0-35-generic x86_64)

 * Documentation:  https://help.ubuntu.com
 * Management:     https://landscape.canonical.com
 * Support:        https://ubuntu.com/advantage

  Get cloud support with Ubuntu Advantage Cloud Guest:
    http://www.ubuntu.com/business/services/cloud

0 packages can be updated.
0 updates are security updates.



The programs included with the Ubuntu system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Ubuntu comes with ABSOLUTELY NO WARRANTY, to the extent permitted by
applicable law.

andrew_kroh@instance-1:~$ wget -qO - https://artifacts.elastic.co/GPG-KEY-elasticsearch | sudo apt-key add -
OK

andrew_kroh@instance-1:~$ sudo apt-get install apt-transport-https
Reading package lists... Done
Building dependency tree       
Reading state information... Done
apt-transport-https is already the newest version (1.2.24).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

andrew_kroh@instance-1:~$ echo "deb https://artifacts.elastic.co/packages/5.x/apt stable main" | sudo tee -a /etc/apt/sources.list.d/elastic-5.x.list
deb https://artifacts.elastic.co/packages/5.x/apt stable main

andrew_kroh@instance-1:~$ sudo apt-get update && sudo apt-get install filebeat
Hit:1 http://europe-west1.gce.archive.ubuntu.com/ubuntu xenial InRelease
Get:2 http://europe-west1.gce.archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]
Get:3 http://europe-west1.gce.archive.ubuntu.com/ubuntu xenial-backports InRelease [102 kB]
Hit:4 http://archive.canonical.com/ubuntu xenial InRelease                                                 
Get:5 http://europe-west1.gce.archive.ubuntu.com/ubuntu xenial/main Sources [868 kB]                 
Get:6 http://europe-west1.gce.archive.ubuntu.com/ubuntu xenial/restricted Sources [4,808 B]                  
Get:7 http://europe-west1.gce.archive.ubuntu.com/ubuntu xenial/universe Sources [7,728 kB]    
Get:8 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]                              
Get:9 http://europe-west1.gce.archive.ubuntu.com/ubuntu xenial/multiverse Sources [179 kB]                            
Get:10 http://europe-west1.gce.archive.ubuntu.com/ubuntu xenial-updates/main Sources [278 kB]
Get:11 http://europe-west1.gce.archive.ubuntu.com/ubuntu xenial-updates/restricted Sources [3,404 B]
Get:12 http://europe-west1.gce.archive.ubuntu.com/ubuntu xenial-updates/universe Sources [176 kB]
Get:13 http://europe-west1.gce.archive.ubuntu.com/ubuntu xenial-updates/multiverse Sources [7,208 B]
Get:14 http://europe-west1.gce.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages [639 kB]
Get:15 http://europe-west1.gce.archive.ubuntu.com/ubuntu xenial-updates/main Translation-en [267 kB]
Get:16 http://europe-west1.gce.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages [538 kB]
Get:17 http://europe-west1.gce.archive.ubuntu.com/ubuntu xenial-updates/universe Translation-en [218 kB]
Ign:18 https://artifacts.elastic.co/packages/5.x/apt stable InRelease               
Get:19 http://europe-west1.gce.archive.ubuntu.com/ubuntu xenial-backports/main Sources [3,432 B]
Get:20 http://europe-west1.gce.archive.ubuntu.com/ubuntu xenial-backports/universe Sources [4,376 B]
Get:21 http://europe-west1.gce.archive.ubuntu.com/ubuntu xenial-backports/main amd64 Packages [4,860 B]
Get:22 https://artifacts.elastic.co/packages/5.x/apt stable Release [4,360 B]
Get:23 https://artifacts.elastic.co/packages/5.x/apt stable Release.gpg [473 B]
Get:24 http://security.ubuntu.com/ubuntu xenial-security/main Sources [93.1 kB]
Get:25 http://security.ubuntu.com/ubuntu xenial-security/restricted Sources [2,600 B]   
Get:26 http://security.ubuntu.com/ubuntu xenial-security/universe Sources [43.4 kB]
Get:27 https://artifacts.elastic.co/packages/5.x/apt stable/main amd64 Packages [26.9 kB]
Get:28 http://security.ubuntu.com/ubuntu xenial-security/multiverse Sources [1,140 B]
Get:29 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages [360 kB]
Get:30 http://security.ubuntu.com/ubuntu xenial-security/main Translation-en [159 kB]
Get:31 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 Packages [169 kB]
Get:32 http://security.ubuntu.com/ubuntu xenial-security/universe Translation-en [90.3 kB]
Fetched 12.2 MB in 2s (4,887 kB/s)                               
Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  filebeat
0 upgraded, 1 newly installed, 0 to remove and 11 not upgraded.
Need to get 9,316 kB of archives.
After this operation, 30.4 MB of additional disk space will be used.
Get:1 https://artifacts.elastic.co/packages/5.x/apt stable/main amd64 filebeat amd64 5.6.2 [9,316 kB]
Fetched 9,316 kB in 1s (5,815 kB/s)    
Selecting previously unselected package filebeat.
(Reading database ... 66553 files and directories currently installed.)
Preparing to unpack .../filebeat_5.6.2_amd64.deb ...
Unpacking filebeat (5.6.2) ...
Processing triggers for systemd (229-4ubuntu19) ...
Processing triggers for ureadahead (0.100.0-19) ...
Setting up filebeat (5.6.2) ...
Processing triggers for systemd (229-4ubuntu19) ...
Processing triggers for ureadahead (0.100.0-19) ...

andrew_kroh@instance-1:~$ filebeat.sh -version
filebeat version 5.6.2 (amd64), libbeat 5.6.2

andrew_kroh@instance-1:~$ exit
logout
Connection to 104.155.xx.xx closed.

(system) #12

This topic was automatically closed after 21 days. New replies are no longer allowed.