Fixed: Cannot yum install Filebeat, broken repo


(Mohd Fadzhli Azmandin) #1

Hi,

I try to yum install filebeat but I think the repo is not working. The repo I'm using is

[beats]
name=Elastic Beats Repository
baseurl=https://packages.elastic.co/beats/yum/el/$basearch
enabled=1
gpgkey=https://packages.elastic.co/GPG-KEY-elasticsearch
gpgcheck=1

Below is my error

Loaded plugins: fastestmirror, langpacks
base                                                                                                                                    | 3.6 kB  00:00:00     
https://packages.elastic.co/beats/yum/el/x86_64/repodata/repomd.xml: [Errno 14] curl#77 - "Problem with the SSL CA cert (path? access rights?)"
Trying other mirror.


 One of the configured repositories failed (Elastic Beats Repository),
 and yum doesn't have enough cached data to continue. At this point the only
 safe thing yum can do is fail. There are a few ways to work "fix" this:

     1. Contact the upstream for the repository and get them to fix the problem.

     2. Reconfigure the baseurl/etc. for the repository, to point to a working
        upstream. This is most often useful if you are using a newer
        distribution release than is supported by the repository (and the
        packages for the previous distribution release still work).

     3. Disable the repository, so yum won't use it by default. Yum will then
        just ignore the repository until you permanently enable it again or use
        --enablerepo for temporary usage:

            yum-config-manager --disable beats

     4. Configure the failing repository to be skipped, if it is unavailable.
        Note that yum will try to contact the repo. when it runs most commands,
        so will have to try and fail each time (and thus. yum will be be much
        slower). If it is a very temporary problem though, this is often a nice
        compromise:

            yum-config-manager --save --setopt=beats.skip_if_unavailable=true

failure: repodata/repomd.xml from beats: [Errno 256] No more mirrors to try.
https://packages.elastic.co/beats/yum/el/x86_64/repodata/repomd.xml: [Errno 14] curl#77 - "Problem with the SSL CA cert (path? access rights?)"

Can someone please check out this repo.

Thank you.


(Mark Walkom) #2

Did you follow these instructions to set it up? https://www.elastic.co/guide/en/beats/filebeat/current/filebeat-installation.html#rpm


(Andrew Kroh) #3

I got a report from a user at ElasticON that there was an issue, but I haven't yet looked into it.


(Mohd Fadzhli Azmandin) #4

No, I'm using these instruction because I want to use yum (more easier to update to new version). https://www.elastic.co/guide/en/beats/filebeat/current/filebeat-installation.html#rpm

I think the problem is with the repo.

Thank you


(Martin Emrich) #5

Hi!

Any news on this? I also try to install via yum, based on this documentation: https://www.elastic.co/guide/en/elasticsearch/reference/current/rpm.html

But I get a 404 on https://artifacts.elastic.co/packages/5.2/yum/repodata/repomd.xml.


(Andrew Kroh) #6

The guide uses 5.x not 5.2.

This works https://artifacts.elastic.co/packages/5.x/yum/repodata/repomd.xml


(Becky Jones) #7

Hi, I'm having this issue too.

I have changed my repo to https://artifacts.elastic.co/packages/5.x/yum as it states in the guide but I get the following error:

yum -y install filebeat
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile

I am a beginner so I'm not quite sure where I am going wrong.


(Andrew Kroh) #8

I just tested installing Filebeat from the yum repo on a clean machine and it worked. Could you try it again?

Try clearing any cached metadata too.

$ yum clean all


(system) #9