Installing Watcher -- pitfall to avoid

alerting

(Curtis) #1

Just ran into this issue installing Watcher and want to get this out there to help someone else who might be having the same problem. The situation looks like a successful Watcher install -- ie
GET /_watcher returns something like
{
"version": {
"name": "1.0.0",
"number": "1.0.0",
"build_hash": "29acda792846b0a35ca224181e8999266f223fb3",
"build_timestamp": "2015-06-26T14:05:54Z",
"build_snapshot": false
}
}

but the following exception is returned when attempting to create a watch

IndexMissingException[[.watches] missing

What I found was the elasticsearch.yml file contained the setting

action.auto_create_index: false

If this setting is false when Watcher is installed the .watches index doesn't seem to get created successfully. The workaround used to resolve the problem was uninstall Watcher, change this setting to true (or just remove it), restart ES, then repeat the steps for installing Watcher. Hope this helps someone else.


(Mark Walkom) #2

Thanks for sharing this, I will pass it onto the Watcher team to see if we can make it easier moving forward!


(Martijn Van Groningen) #3

From 2.0 Watcher won't start if the action.auto_create_index setting is too restrictive:
https://www.elastic.co/guide/en/watcher/current/release-notes.html#_2_0_0


(Curtis) #4

Thank you for the information. A previous version of Watcher was being installed so the descriptive message wasn't returned. Looking forward to trying 2.0


(system) #5