Io/console not supported when starting logstash 1.5.0 on Win 7

I'm trying to get ELK setup on a Win 7 machine using Java 1.8 . I've got E and K and marvel running but I can't get logstash to startup.

From a windows command console running with admin previlages on a folder on the desktop (where ES and Kibana run happily) when I run logstash.bat I get

Microsoft Windows [Version 6.1.7601]

io/console not supported; tty will not be manipulated
No command given

Usage: logstash <command> [command args]
Run a command with the --help flag to see the arguments.
For example: logstash agent --help

Available commands:
  agent - runs the logstash agent
  version - emits version info about this logstash

if I run

logstash version

I get

io/console not supported; tty will not be manipulated
logstash 1.5.0

If I run logstash agent its looks for config files to test but I don't have any of them (do I ?)

Also noticed in the logstash folder there are various files which seems to be the output of the getting started command from here but marvel only shows the kibana marvel and kibana.marvel indexes

Any pointers on how to make sure Logstash is running properly on windows and it can feed ES?

You do need to define your own config files, you can't run LS without them (or it'll start and then bail immediately).

Ooops can't get more novice a mistake than that I'd say :smile: . Thanks for the pointer

I get the same error on Win7 using Cygwin terminal:

While the OP needed to know about parameters, this error is not related to that. I cannot get Logstash to use my conf file to start up and get this error, too:

sml@sml-co-lt2 ~/logstash-1.5.2
$ bin/logstash agent -f found.conf
io/console not supported; tty will not be manipulated
{:timestamp=>"2015-07-09T15:27:03.971000-0700", :message=>"Failed to install template: connect timed out", :level=>:error}

Do you think that is related?

This is a problem talking to ES, so not related.

Thanks, how can I test/debug why my local logstash is not talking to my Elasticsearch instance in Found? I can post via curl to it with the same uri but using the conf file below, it throws the error:

input { stdin{} }

output {
elasticsearch {
protocol => http
host => a6793c--OBSCURED--cd8e7
port => 9243 # Check the port also
ssl => true

stdout { codec => rubydebug }

Looks like your host string is incomplete?

Yes, I got this working now, thanks!

The next command works for me in windows:
bin\logstash.bat -e 'input { stdin {} } output { stdout {} }'