Is an old mapping file cached?


(Dan Tuffery) #1

I am having an issue on one of my servers, I have updated the mapping file
in '/elasticsearch/data/config/templates' and I cleared the index, but when
I try and index a document I complains that one of the analyzers is
missing. It seems like some old mapping file is cached somewhere and it is
using that instead of the new one I just installed.

I tried the same set up locally - same mapping file and indexed the same
json - and it worked OK.

Does anyone know what is going on here?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Rafał Kuć) #2

Hello!

Did you delete the index or only deleted the documents in the index?

--

Regards,

Rafał Kuć

Sematext :: http://sematext.com/ :: Solr - Lucene - ElasticSearch

I am having an issue on one of my servers, I have updated the mapping file in '/elasticsearch/data/config/templates' and I cleared the index, but when I try and index a document I complains that one of the analyzers is missing. It seems like some old mapping file is cached somewhere and it is using that instead of the new one I just installed.

I tried the same set up locally - same mapping file and indexed the same json - and it worked OK.

Does anyone know what is going on here?

--

You received this message because you are subscribed to the Google Groups "elasticsearch" group.

To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.


(Dan Tuffery) #3

I deleted the index.

On Friday, October 4, 2013 12:12:01 PM UTC+1, Rafał Kuć wrote:

Hello!

Did you delete the index or only deleted the documents in the index?

*--
Regards,
Rafał Kuć
Sematext :: http://sematext.com/ :: Solr - Lucene - ElasticSearch

I am having an issue on one of my servers, I have updated the mapping
file in '/elasticsearch/data/config/templates' and I cleared the index, but
when I try and index a document I complains that one of the analyzers is
missing. It seems like some old mapping file is cached somewhere and it is
using that instead of the new one I just installed.

I tried the same set up locally - same mapping file and indexed the same
json - and it worked OK.

Does anyone know what is going on here?

You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Rafał Kuć) #4

Hello!

OK. Is you server in a cluster? If so, did you put the updated templates on all nodes that can work as master? I assume that the path you've shown is the proper one for config.

--

Regards,

Rafał Kuć

Sematext :: http://sematext.com/ :: Solr - Lucene - ElasticSearch

I deleted the index.

On Friday, October 4, 2013 12:12:01 PM UTC+1, Rafał Kuć wrote:

Hello!

Did you delete the index or only deleted the documents in the index?

--

Regards,

Rafał Kuć

Sematext :: http://sematext.com/ :: Solr - Lucene - ElasticSearch

I am having an issue on one of my servers, I have updated the mapping file in '/elasticsearch/data/config/templates' and I cleared the index, but when I try and index a document I complains that one of the analyzers is missing. It seems like some old mapping file is cached somewhere and it is using that instead of the new one I just installed.

I tried the same set up locally - same mapping file and indexed the same json - and it worked OK.

Does anyone know what is going on here?

--

You received this message because you are subscribed to the Google Groups "elasticsearch" group.

To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.--

You received this message because you are subscribed to the Google Groups "elasticsearch" group.

To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.


(Dan Tuffery) #5

Something else that is odd. After I delete the index, I tried to query the
index and instead of giving me an Exception saying the index doesn't exist
it returns an empty result. Something is creating an index with the index
name I am using.

On Friday, October 4, 2013 12:08:31 PM UTC+1, dan wrote:

I am having an issue on one of my servers, I have updated the mapping file
in '/elasticsearch/data/config/templates' and I cleared the index, but when
I try and index a document I complains that one of the analyzers is
missing. It seems like some old mapping file is cached somewhere and it is
using that instead of the new one I just installed.

I tried the same set up locally - same mapping file and indexed the same
json - and it worked OK.

Does anyone know what is going on here?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Dan Tuffery) #6

Thanks for your response.

No, it is not part of a cluster, it is an ES instance with the same
configurations that come OOTB. The only custom config is my mapping file.

Yes, that is is the correct path, it works on my other servers.

On Friday, October 4, 2013 12:21:30 PM UTC+1, Rafał Kuć wrote:

Hello!

OK. Is you server in a cluster? If so, did you put the updated templates
on all nodes that can work as master? I assume that the path you've shown
is the proper one for config.

*--
Regards,
Rafał Kuć
Sematext :: http://sematext.com/ :: Solr - Lucene - ElasticSearch

I deleted the index.

On Friday, October 4, 2013 12:12:01 PM UTC+1, Rafał Kuć wrote:
Hello!

Did you delete the index or only deleted the documents in the index?

*--
Regards,
Rafał Kuć
Sematext :: http://sematext.com/ :: Solr - Lucene - ElasticSearch

I am having an issue on one of my servers, I have updated the mapping
file in '/elasticsearch/data/config/templates' and I cleared the index, but
when I try and index a document I complains that one of the analyzers is
missing. It seems like some old mapping file is cached somewhere and it is
using that instead of the new one I just installed.

I tried the same set up locally - same mapping file and indexed the same
json - and it worked OK.

Does anyone know what is going on here?

You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.https://groups.google.com/groups/opt_out
com/groups/opt_out https://groups.google.com/groups/opt_out. --
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #7