Is it possible to disable sending metrics for specific transactions/endpoints?

If you are asking about a problem you are experiencing, please use the following template, as it will help us help you. If you have a different problem, please delete all of this text :slight_smile:

Kibana version : 7.6.2

Elasticsearch version : 7.6.2

APM Server version : 7.6.2

APM Agent language and version : Ruby 3.6.0

Browser version : Chrome

Original install method (e.g. download page, yum, deb, from source, etc.) and version :

Fresh install or upgraded from other version? : fresh install

Is there anything special in your setup? For example, are you using the Logstash or Kafka outputs? Are you using a load balancer in front of the APM Servers? Have you changed index pattern, generated custom templates, changed agent configuration etc.

Description of the problem including expected versus actual behavior. Please include screenshots (if relevant) : Hello, I'm running Rails 5.0 and was wondering if there is a way to disable the sending of metrics for specific transactions. For example, my app has a health controller for health checks, and I don't want agents to send metrics for this endpoint to the apm server. Can I do this? Is it possible to simply add a before_action callback on the health controller that ends the current transaction? Thanks!

Steps to reproduce :
1.
2.
3.

Errors in browser console (if relevant) :

Provide logs and/or server output (if relevant) :