Is JMS output even possible?

I'm hoping someone here can provide just a basic example of using the logstash-output-jms plugin for logstash. The site itself has no info and I can find no config examples for output anywhere. Is this a valid plugin ?
I just need to write messages to an activeMQ queue. I have tried the stomp output but that writes blank messages. Any suggestions ?

The stomp output (with host, port and destination) is the way to go. With ActiveMQ you need to start your broker with stomp enabled (I guess you have otherwise you'd have connections issues)

Can you provide your current Logstash config and maybe a sample event that you're sending?

Thank you for your prompt reply.

I had tried the stomp output first but I got only empty message bodies. After some googling it looked like I needed to set a header value - "amq-msg-type" => "text". Problem is that a pull request to merge that feature in the stomp plugin was denied the previous day.

Looking through the JMS output src and underlying jruby I got it working so below is an example for any other folks looking. It actually turned out to be a simple config.
The commented lines are what did not work from the given example at the top of the src.

from output in logstash conf file:
jms {
#include_header => false
#include_properties => false
#include_body => true
#use_jms_timestamp => false
yaml_file => "/usr/local/logstash/conf.d/jms.yml"
#queue_name => "outputstomp"
destination => "outputstomp"
pub_sub => false
yaml_section => "activemq"

YAML file:
# Active MQ Centralized Broker
  :factory: org.apache.activemq.ActiveMQConnectionFactory
  :broker_url: tcp://
  :username: admin
  :password: xxxxx
    - /usr/local/activemq/activemq-all-5.10.0.jar
    - /usr/local/activemq/lib/optional/log4j-1.2.17.jar
1 Like

The pull request was denied because message headers have been included in another pull request two days ago.

Since then a new version of the stomp output was released (2.0.5) with headers support. You should uninstall/reinstall the logstash-output-stomp plugin and it will work.