Is kibana send e-mail bug fixed in 6.1.2?


(yuluopiaoyang) #1

Is kibana alert send e-mail bug fixed in 6.1.2? I still can't send e-mail.Or I have some wrong in config?This is my config.
xpack.notification.email.account:
outlook_account:
profile: outlook
email_defaults:
from: cipublic@xxxx.com
smtp:
auth: true
starttls.enable: true
host: smtpscn.xxxx.com
port: 50
user: pmail_CIpublic
password: XXXXX

My mailbox is inside company mailbox.Is the port number must 587 or any other port number?
Is the profile config outlook or standard?


(Mark Walkom) #2

How long have you had this issue?
What do your logs say?


(yuluopiaoyang) #3

Thank you for your respond.I just updated the kibana version from 6.1.1 to 6.1.2 yesterday. I used docker image to install kibana, and I don't know where to find the log. Can you tell me the log dir?


(yuluopiaoyang) #4

Hi,I have found the kibana log, there is a request timeout wrong in the log, I think maybe I need to see the detail in elastic log. Then I config the elastic path.logs, then reinstall the elastic. The log path was generated but the path is empty, I can't find the log file,can you help me? Thank you!


(yuluopiaoyang) #5

I just test fire an e-mail now, I found a error in kibana log

{"type":"error","@timestamp":"2018-01-30T03:48:36Z","tags":[],"pid":1,"level":"error","error":{"message":"Request Timeout after 30000ms","name":"Error","stack":"Error
: Request Timeout after 30000ms\n at /usr/share/kibana/node_modules/elasticsearch/src/lib/transport.js:342:15\n at Timeout. (/usr/share/kibana/node_m
odules/elasticsearch/src/lib/transport.js:371:7)\n at ontimeout (timers.js:386:11)\n at tryOnTimeout (timers.js:250:5)\n at Timer.listOnTimeout (timers.js:21
4:5)"},"url":{"protocol":null,"slashes":null,"auth":null,"host":null,"port":null,"hostname":null,"hash":null,"search":"","query":{},"pathname":"/api/watcher/watch/exe
cute","path":"/api/watcher/watch/execute","href":"/api/watcher/watch/execute"},"message":"Request Timeout after 30000ms"}

How can I solve it? Thank you!


(yuluopiaoyang) #6

There is another error.
{"type":"error","@timestamp":"2018-01-30T03:37:47Z","tags":[],"pid":1,"level":"error","error":{"message":"json argument must contain a watchStatusJson property","name
":"Error","stack":"Error: json argument must contain a watchStatusJson property\n at Function.fromUpstreamJson (/usr/share/kibana/plugins/x-pack/plugins/watcher/se
rver/models/watch_status/watch_status.js:128:13)\n at new WatchHistoryItem (/usr/share/kibana/plugins/x-pack/plugins/watcher/server/models/watch_history_item/watch
_history_item.js:17:36)\n at Function.fromUpstreamJson (/usr/share/kibana/plugins/x-pack/plugins/watcher/server/models/watch_history_item/watch_history_item.js:43:
12)\n at executeWatch.then.hit (/usr/share/kibana/plugins/x-pack/plugins/watcher/server/routes/api/watch/register_execute_route.js:43:51)\n at tryCatcher (/usr/
share/kibana/node_modules/bluebird/js/main/util.js:26:23)\n at Promise._settlePromiseFromHandler (/usr/share/kibana/node_modules/bluebird/js/main/promise.js:503:31
)\n at Promise._settlePromiseAt (/usr/share/kibana/node_modules/bluebird/js/main/promise.js:577:18)\n at Promise._settlePromises (/usr/share/kibana/node_modules
/bluebird/js/main/promise.js:693:14)\n at Async._drainQueue (/usr/share/kibana/node_modules/bluebird/js/main/async.js:123:16)\n at Async._drainQueues (/usr/shar
e/kibana/node_modules/bluebird/js/main/async.js:133:10)\n at Immediate.Async.drainQueues (/usr/share/kibana/node_modules/bluebird/js/main/async.js:15:14)\n at r
unCallback (timers.js:672:20)\n at tryOnImmediate (timers.js:645:5)\n at processImmediate [as _immediateCallback] (timers.js:617:5)"},"url":{"protocol":null,"sl
ashes":null,"auth":null,"host":null,"port":null,"hostname":null,"hash":null,"search":"","query":{},"pathname":"/api/watcher/watch/execute","path":"/api/watcher/watch/
execute","href":"/api/watcher/watch/execute"},"message":"json argument must contain a watchStatusJson property"}

Can you help me? I have been blocked several days.


(yuluopiaoyang) #7

OK. I have solved this problem.


(Mark Walkom) #8

What was the solution?


(yuluopiaoyang) #9

Use the default auth,starttls.enable and port config. Then it is work.


(yuluopiaoyang) #10

I think the port config value 587 on the official website confused me. I suggest change it.


(system) #11

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.