Is TTL config change in 1.2?


(seb-2) #1

Hi

I used to create index with a TTL like this

curl -X POST http://localhost:9200/index_test -d '{
"mappings":{
"document":{
"_ttl":{
"enable":true
},
"properties":{
"text":{
"type":"string"
}
}
}
},
"settings":{
"number_of_replicas":1,
"number_of_shards":1,
}
}
}'

and when I check http://localhost:9298/index_test/_mapping I have

{
"index_test" : {
"mappings" : {
"document" : {
"_ttl" : {
"enabled" : true
},
"properties" : {
"text" : {
"type" : "string"
}
}
}
}
}
}

Every thing works perfectly but On my last update to 1.2 when I
check http://localhost:9298/index_test/_mapping I only have

{
"index_test" : {
"mappings" : {
"properties" : {
"text" : {
"type" : "string"
}
}
}
}
}
}

ttl has gone and ttl don't work anymore. Is there a new setting for TTL?
Thanks a lot

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/098f4d11-33ee-4b08-a619-069e36043a06%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(seb-2) #2

sorry typo: enable vs enabled

On Saturday, July 5, 2014 5:59:31 PM UTC+2, seb wrote:

Hi

I used to create index with a TTL like this

curl -X POST http://localhost:9200/index_test -d '{
"mappings":{
"document":{
"_ttl":{
"enable":true
},
"properties":{
"text":{
"type":"string"
}
}
}
},
"settings":{
"number_of_replicas":1,
"number_of_shards":1,
}
}
}'

and when I check http://localhost:9298/index_test/_mapping I have

{
"index_test" : {
"mappings" : {
"document" : {
"_ttl" : {
"enabled" : true
},
"properties" : {
"text" : {
"type" : "string"
}
}
}
}
}
}

Every thing works perfectly but On my last update to 1.2 when I check
http://localhost:9298/index_test/_mapping I only have

{
"index_test" : {
"mappings" : {
"properties" : {
"text" : {
"type" : "string"
}
}
}
}
}
}

ttl has gone and ttl don't work anymore. Is there a new setting for TTL?
Thanks a lot

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/34b47d96-53d1-4fcc-a8b6-907a231cacfe%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #3