Issue (Bug?) with field_value_factor and Search Template


(germap) #1

Hi,

I'm getting the following error message while attempting to use the Search
Template (I use ES 1.3.1):

nested: ElasticsearchException[Unable to find a field mapper for field
[weight]

I' m storing the template in the .script index as stated here [1]. The
field 'weight' is used inside a field_value_factor (function_score).

The query runs appropriately when not using a Search Template.

You can find a mapping, sample data, working query, sample template, and a
not working template query at [2].
Is that a bug?

I'd appreciate any help,

Germán


[1] http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/search-template.html#_filling_in_a_query_string_with_a_single_value
[2] https://titanpad.com/es-fvf-issue

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/65d2ceb8-37cb-4f61-92e6-e85c0c4f0b6e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(germap) #2

It seems I was taking too literally the Search Template documentation [1]
(or perhaps it lacks a small note on search paths).

If I use what is stated in [1] I get the error I mentioned in the first
post of this thread. Nonetheless, If I specify the full path in the POST
query, ES returns what is expected.

i.e., POST _search/template doesn't work, but POST
/books/authors/_search/template does.

Regards,

Germán

[1]
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/search-template.html

2014-07-31 16:52 GMT-05:00 German Carrillo carrillo.german@gmail.com:

Hi,

I'm getting the following error message while attempting to use the Search
Template (I use ES 1.3.1):

nested: ElasticsearchException[Unable to find a field mapper for field
[weight]

I' m storing the template in the .script index as stated here [1]. The
field 'weight' is used inside a field_value_factor (function_score).

The query runs appropriately when not using a Search Template.

You can find a mapping, sample data, working query, sample template, and a
not working template query at [2].
Is that a bug?

I'd appreciate any help,

Germán


[1]
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/search-template.html#_filling_in_a_query_string_with_a_single_value
[2] https://titanpad.com/es-fvf-issue

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/65d2ceb8-37cb-4f61-92e6-e85c0c4f0b6e%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/65d2ceb8-37cb-4f61-92e6-e85c0c4f0b6e%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CANaz7mz6h7ipj%2BmwtPbPUGOkc5Q%2BWGHgiqOZZUksOMzBGXvWqA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #3