Issue restarting Elasticsearch with mlockall = true

Hello,

I am running in to an issue with Elasticsearch on Ubuntu with mlockall set
to true. If I have mlockall enabled and I go to restart elasticsearch I
get the following error:

Error occurred during initialization of VM
Could not reserve enough space for object heap

But if I do a stop and start its fine. I am using the chef cookbook to
deploy ES and the default setting of 60% of system memory set to the ES
java Heap (System has 15GB of ram). Something I am missing on the
configuration to allow me to use mlockall and still restart ES? Should I
just use 50% of the system memory?

Zuhaib

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Error occurred during initialization of VM
Could not reserve enough space for object heap

But if I do a stop and start its fine. I am using the chef cookbook to
deploy ES and the default setting of 60% of system memory set to the ES
java Heap (System has 15GB of ram). Something I am missing on the
configuration to allow me to use mlockall and still restart ES? Should I
just use 50% of the system memory?

The restart script in the Chef cookbook [1] does just that, stop => start.
What kind of system is this on? Is it a virtual machine, Vagrant?

Karel

[1] https://github.com/elasticsearch/cookbook-elasticsearch

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.