Issue with installing elasticsearch in windows 8.1

I'm running Windows 8.1 on my laptop and I tried to install elastic search but I'm getting the following error :
\Java\jdk1.7.0_45\bin\java.exe was unexpected at this time.
after this error appeard I installed oracle jdk 8 update 45 and set the java_home and path but still I'm getting the same error
what should I do ?
thanks ...

You mean? the exact same error?

Did you restart the CMD window?
May be a PATH issue?

Which Elasticsearch version?

excuse me because I didn't fill the data completely ...
the version of elasticsearch is 5.0.0-alpha4 and the error that I mentioned to was exact error that I got
and I'm sure that I have set the PATH value correctly
but now another error is appearing ...
Error occurred during initialization of VM
Could not reserve enough space for 2097152KB object heap
I have tried this link but it didn't worked for me ....
My machine configuration :
wndows 8.1 64bit
4 GB ram

May be you have some other services running on Windows and you don't have 2Gb of free RAM available?

Yes thanks you were right ...