It does not work "Stop Word"

*Hello!

It does not work "Stop Word"

I have this mapping:*

fos_elastica:
clients:
default: {host: localhost, port: 9200}
indexes:
website:
settings:
index:
analysis:
analyzer:
my_analyzer:
language: english
tokenizer: nonutf8letter
filter: [standard, lowercase, asciifolding,
stop, custom_stop]
tokenizer:
nonutf8letter:
type: pattern
pattern: '[^ \ pL \ pM \ p {Nd} \ p {Nl} \
p {Pc} [\ p {InEnclosedAlphanumerics} && \ p {So}]]'
filter:
custom_stop:
type: length
min: 3
max: 2000
types:
deals:
mappings:
id: boost {3}
nombreoa {analyzer: my_analyzer}
idareaestudio:
type: "nested"
properties:
name: {type: String, index: not_analyzed}
*
When I search "to" bring me everything and I want it excluded.

Any idea what I do wrong?*

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Hi,
It's hard to determine the issue with seeing the data getting indexed and
the search that is ran. if you create a recreation following the below
guidelines, you're much more likely to get accurate answers.
http://www.elasticsearch.org/help/

Best Regards,
Paul

On Friday, July 26, 2013 11:39:36 AM UTC-6, Rebeca De San Martin wrote:

*Hello!

It does not work "Stop Word"

I have this mapping:*

fos_elastica:
clients:
default: {host: localhost, port: 9200}
indexes:
website:
settings:
index:
analysis:
analyzer:
my_analyzer:
language: english
tokenizer: nonutf8letter
filter: [standard, lowercase,
asciifolding, stop, custom_stop]
tokenizer:
nonutf8letter:
type: pattern
pattern: '[^ \ pL \ pM \ p {Nd} \ p {Nl}
\ p {Pc} [\ p {InEnclosedAlphanumerics} && \ p {So}]]'
filter:
custom_stop:
type: length
min: 3
max: 2000
types:
deals:
mappings:
id: boost {3}
nombreoa {analyzer: my_analyzer}
idareaestudio:
type: "nested"
properties:
name: {type: String, index: not_analyzed}
*
When I search "to" bring me everything and I want it excluded.

Any idea what I do wrong?*

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

If I search "to" should exclude all results and get me 0 results and what
they are doing is bringing me all results where it finds "a". It does not
work.

El viernes, 26 de julio de 2013 14:39:36 UTC-3, Rebeca De San Martin
escribió:

*Hello!

It does not work "Stop Word"

I have this mapping:*

fos_elastica:
clients:
default: {host: localhost, port: 9200}
indexes:
website:
settings:
index:
analysis:
analyzer:
my_analyzer:
language: english
tokenizer: nonutf8letter
filter: [standard, lowercase,
asciifolding, stop, custom_stop]
tokenizer:
nonutf8letter:
type: pattern
pattern: '[^ \ pL \ pM \ p {Nd} \ p {Nl}
\ p {Pc} [\ p {InEnclosedAlphanumerics} && \ p {So}]]'
filter:
custom_stop:
type: length
min: 3
max: 2000
types:
deals:
mappings:
id: boost {3}
nombreoa {analyzer: my_analyzer}
idareaestudio:
type: "nested"
properties:
name: {type: String, index: not_analyzed}
*
When I search "to" bring me everything and I want it excluded.

Any idea what I do wrong?*

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Sorry, still need more context to be of any help. Can you please create a
curl based recreation as described here:
http://www.elasticsearch.org/help/

Minimally, I need to see how the index is created, how the data is indexed,
and how the data is searched.

Best Regards,
Paul

On Monday, July 29, 2013 6:18:19 AM UTC-6, Rebeca De San Martin wrote:

If I search "to" should exclude all results and get me 0 results and
what they are doing is bringing me all results where it finds "a". It
does not work.

El viernes, 26 de julio de 2013 14:39:36 UTC-3, Rebeca De San Martin
escribió:

*Hello!

It does not work "Stop Word"

I have this mapping:*

fos_elastica:
clients:
default: {host: localhost, port: 9200}
indexes:
website:
settings:
index:
analysis:
analyzer:
my_analyzer:
language: english
tokenizer: nonutf8letter
filter: [standard, lowercase,
asciifolding, stop, custom_stop]
tokenizer:
nonutf8letter:
type: pattern
pattern: '[^ \ pL \ pM \ p {Nd} \ p {Nl}
\ p {Pc} [\ p {InEnclosedAlphanumerics} && \ p {So}]]'
filter:
custom_stop:
type: length
min: 3
max: 2000
types:
deals:
mappings:
id: boost {3}
nombreoa {analyzer: my_analyzer}
idareaestudio:
type: "nested"
properties:
name: {type: String, index: not_analyzed
}
*
When I search "to" bring me everything and I want it excluded.

Any idea what I do wrong?*

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Here's a tip that might help... I like to use facets in order to determine
what terms are actually being stored in the underlying engine.

So run a query for your specific document and add a facet on the field you
are having issues with. That will show you if stopwords are actually making
it into the index or something else is going on.

Best Regards,
Paul

On Monday, July 29, 2013 11:57:13 AM UTC-6, ppearcy wrote:

Sorry, still need more context to be of any help. Can you please create a
curl based recreation as described here:
http://www.elasticsearch.org/help/

Minimally, I need to see how the index is created, how the data is
indexed, and how the data is searched.

Best Regards,
Paul

On Monday, July 29, 2013 6:18:19 AM UTC-6, Rebeca De San Martin wrote:

If I search "to" should exclude all results and get me 0 results and
what they are doing is bringing me all results where it finds "a". It
does not work.

El viernes, 26 de julio de 2013 14:39:36 UTC-3, Rebeca De San Martin
escribió:

*Hello!

It does not work "Stop Word"

I have this mapping:*

fos_elastica:
clients:
default: {host: localhost, port: 9200}
indexes:
website:
settings:
index:
analysis:
analyzer:
my_analyzer:
language: english
tokenizer: nonutf8letter
filter: [standard, lowercase,
asciifolding, stop, custom_stop]
tokenizer:
nonutf8letter:
type: pattern
pattern: '[^ \ pL \ pM \ p {Nd} \ p {Nl
} \ p {Pc} [\ p {InEnclosedAlphanumerics} && \ p {So}]]'
filter:
custom_stop:
type: length
min: 3
max: 2000
types:
deals:
mappings:
id: boost {3}
nombreoa {analyzer: my_analyzer}
idareaestudio:
type: "nested"
properties:
name: {type: String, index:
not_analyzed}
*
When I search "to" bring me everything and I want it excluded.

Any idea what I do wrong?*

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

My query combines:
this:
http://www.elasticsearch.org/guide/reference/query-dsl/filtered-query/*
this: *http://www.elasticsearch.org/guide/reference/query-dsl/nested-filter/
*and this: *
http://www.elasticsearch.org/guide/reference/query-dsl/dis-max-query/

*and works perfectly for what I need.
I just need to add that excluded 2-letter words. Nothing more ..!
So hard to understand is it?
*

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

It is very hard to understand without any real details :slight_smile:

All I can do at this point is show you a recreation of things working:

Please provide a reproduction to allow others to reproduce and troubleshoot
the issue or you are likely on your own.

Best Regards,
Paul

On Monday, July 29, 2013 1:35:33 PM UTC-6, Rebeca De San Martin wrote:

My query combines:
this:
http://www.elasticsearch.org/guide/reference/query-dsl/filtered-query/*
this: *
http://www.elasticsearch.org/guide/reference/query-dsl/nested-filter/
*and this: *
http://www.elasticsearch.org/guide/reference/query-dsl/dis-max-query/

*and works perfectly for what I need.
I just need to add that excluded 2-letter words. Nothing more ..!
So hard to understand is it?
*

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.