Java Client Connection Errors on Upgrade from 0.19.11 to 1.0.0.Beta2


(davrob) #1

Hi,

So, after the upgrade I now can't connect using a java client node using:

Node hostNode = NodeBuilder.nodeBuilder()
.loadConfigSettings(false)
.settings(settings)
.node()
.start();

with these client settings:

index.number_of_shards=1,
index.number_of_replicas=1,
cluster.name=CMTDEV1,
node.client=true,
index.mapper=dynamic:false,
node.data=false,
transport.tcp.port=9400-9450,
http.port=9451-9500,
node.name=David-Roberts-Local_166.15.121.56,
network.host=166.15.121.56,
discovery.zen.ping.unicast.enabled=true,
http.enabled=true,
discovery.zen.ping.unicast.hosts:9400=vcll36a-1001.equity.csfb.com,vcll36a-1001.equity.csfb.com:9401,vcll36a-1001.equity.csfb.com:9402,vcll36a-1001.equity.csfb.com:9403,vcll36a-1001.equity.csfb.com:9404,vcll36a-1001.equity.csfb.com:9405,vcll36a-1001.equity.csfb.com:9406,vcll36a-1001.equity.csfb.com:9407,vcll36a-1001.equity.csfb.com:9408,vcll36a-1001.equity.csfb.com:9409,vcll36a-1001.equity.csfb.com:9410,

discovery.zen.ping.multicast.enabled=false

The error thrown on the client is this:

[CMLM]2014-01-03 18:08:05,251 INFO zen:114 -
[David-Roberts-Local_166.15.121.56] failed to send join request to master
[[Cheetah][Y-Bo59_1Se-fSsAkz1bqKw][inet[/169.36.78.96:9401]]], reason
[org.elasticsearch.transport.RemoteTransportException:
[Cheetah][inet[/169.36.78.96:9401]][discovery/zen/join];
org.elasticsearch.ElasticSearchTimeoutException: Timeout waiting for task.]

This server and client combination was fine using 0.19.11, so
ports/firewalls is probably not the issue.

The sever startup log is here: https://gist.github.com/dav-rob/8243260

The server config is here: https://gist.github.com/dav-rob/8243311

The serer command line is here: https://gist.github.com/dav-rob/8243336

Thanks,

David.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/3a8358b4-0188-4654-9c07-df77b5ed4300%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Alexander Reelsen) #2

Hey,

just to make sure: You are using the same elasticsearch version and the
same jvm version (including the minor/release version) on the server and
client side?

--Alex

On Fri, Jan 3, 2014 at 7:24 PM, davrob2 daviroberts@gmail.com wrote:

Hi,

So, after the upgrade I now can't connect using a java client node using:

Node hostNode = NodeBuilder.nodeBuilder()
.loadConfigSettings(false)
.settings(settings)
.node()
.start();

with these client settings:

index.number_of_shards=1,
index.number_of_replicas=1,
cluster.name=CMTDEV1,
node.client=true,
index.mapper=dynamic:false,
node.data=false,
transport.tcp.port=9400-9450,
http.port=9451-9500,
node.name=David-Roberts-Local_166.15.121.56,
network.host=166.15.121.56,
discovery.zen.ping.unicast.enabled=true,
http.enabled=true,
discovery.zen.ping.unicast.hosts:9400=vcll36a-1001.equity.csfb.com,
vcll36a-1001.equity.csfb.com:9401,vcll36a-1001.equity.csfb.com:9402,
vcll36a-1001.equity.csfb.com:9403,vcll36a-1001.equity.csfb.com:9404,
vcll36a-1001.equity.csfb.com:9405,vcll36a-1001.equity.csfb.com:9406,
vcll36a-1001.equity.csfb.com:9407,vcll36a-1001.equity.csfb.com:9408,
vcll36a-1001.equity.csfb.com:9409,vcll36a-1001.equity.csfb.com:9410,

discovery.zen.ping.multicast.enabled=false

The error thrown on the client is this:

[CMLM]2014-01-03 18:08:05,251 INFO zen:114 -
[David-Roberts-Local_166.15.121.56] failed to send join request to master
[[Cheetah][Y-Bo59_1Se-fSsAkz1bqKw][inet[/169.36.78.96:9401]]], reason
[org.elasticsearch.transport.RemoteTransportException:
[Cheetah][inet[/169.36.78.96:9401]][discovery/zen/join];
org.elasticsearch.ElasticSearchTimeoutException: Timeout waiting for task.]

This server and client combination was fine using 0.19.11, so
ports/firewalls is probably not the issue.

The sever startup log is here: https://gist.github.com/dav-rob/8243260

The server config is here: https://gist.github.com/dav-rob/8243311

The serer command line is here: https://gist.github.com/dav-rob/8243336

Thanks,

David.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/3a8358b4-0188-4654-9c07-df77b5ed4300%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGCwEM9AueYhi_7w%2Brbc%2B%3D%2BoFF2uQA%3D66B-JZ6%3DHrprfA-m3CQ%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(davrob) #3

Hi Alexander,

Yes, there was potentially an issue with JVM versions which I have address,
however, I am still having issue, which I have tried to address with a more
simplified configuration - based on the out of the box elasticsearch,
rather than the config I've been using for the last couple of years. I
created a new thread, based on that configuration: Beta2
UnresolvedAddressExceptionhttps://groups.google.com/forum/?safe=on#!searchin/elasticsearch/dav-rob|sort:date/elasticsearch/n-4EsFeFKm0/RsORoIHCCzQJ.
Thanks, David.

On Wednesday, 8 January 2014 13:14:38 UTC, Alexander Reelsen wrote:

Hey,

just to make sure: You are using the same elasticsearch version and the
same jvm version (including the minor/release version) on the server and
client side?

--Alex

On Fri, Jan 3, 2014 at 7:24 PM, davrob2 <davir...@gmail.com <javascript:>>wrote:

Hi,

So, after the upgrade I now can't connect using a java client node using:

Node hostNode = NodeBuilder.nodeBuilder()
.loadConfigSettings(false)
.settings(settings)
.node()
.start();

with these client settings:

index.number_of_shards=1,
index.number_of_replicas=1,
cluster.name=CMTDEV1,
node.client=true,
index.mapper=dynamic:false,
node.data=false,
transport.tcp.port=9400-9450,
http.port=9451-9500,
node.name=David-Roberts-Local_166.15.121.56,
network.host=166.15.121.56,
discovery.zen.ping.unicast.enabled=true,
http.enabled=true,
discovery.zen.ping.unicast.hosts:9400=vcll36a-1001.equity.csfb.com,
vcll36a-1001.equity.csfb.com:9401,vcll36a-1001.equity.csfb.com:9402,
vcll36a-1001.equity.csfb.com:9403,vcll36a-1001.equity.csfb.com:9404,
vcll36a-1001.equity.csfb.com:9405,vcll36a-1001.equity.csfb.com:9406,
vcll36a-1001.equity.csfb.com:9407,vcll36a-1001.equity.csfb.com:9408,
vcll36a-1001.equity.csfb.com:9409,vcll36a-1001.equity.csfb.com:9410,

discovery.zen.ping.multicast.enabled=false

The error thrown on the client is this:

[CMLM]2014-01-03 18:08:05,251 INFO zen:114 -
[David-Roberts-Local_166.15.121.56] failed to send join request to master
[[Cheetah][Y-Bo59_1Se-fSsAkz1bqKw][inet[/169.36.78.96:9401]]], reason
[org.elasticsearch.transport.RemoteTransportException:
[Cheetah][inet[/169.36.78.96:9401]][discovery/zen/join];
org.elasticsearch.ElasticSearchTimeoutException: Timeout waiting for task.]

This server and client combination was fine using 0.19.11, so
ports/firewalls is probably not the issue.

The sever startup log is here: https://gist.github.com/dav-rob/8243260

The server config is here: https://gist.github.com/dav-rob/8243311

The serer command line is here: https://gist.github.com/dav-rob/8243336

Thanks,

David.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/3a8358b4-0188-4654-9c07-df77b5ed4300%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/f59eb9ad-07d9-40a3-8529-671607c86d7f%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #4