Java client --> EC2 --> ES


(achaayan) #1

Hi,
I have set up ES server in AWS, and it seems to be working fine. I am
trying to connect programmatically to this server from my java client, by
creating a node (java application is running outside the cloud). However, I
am getting binding error : https://gist.github.com/1376202

It this possible? Please let me know if I am doing something wrong.

My Java node object is created with following attributes:

cluster.name :
network.host : (In server, I have
configured this name with private IP of server)
discovery.type : ec2
cloud.account :
cloud.key:


(avasilenko) #2

Hello Achaayan,

Remove :9300 part from network.host

Regards,
Alexandr Vasilenko

2011/11/18 achaayan felixmd@gmail.com

Hi,
I have set up ES server in AWS, and it seems to be working fine. I am
trying to connect programmatically to this server from my java client, by
creating a node (java application is running outside the cloud). However, I
am getting binding error : https://gist.github.com/1376202

It this possible? Please let me know if I am doing something wrong.

My Java node object is created with following attributes:

cluster.name :
network.host : (In server, I have
configured this name with private IP of server)
discovery.type : ec2
cloud.account :
cloud.key:


(achaayan) #3

Thanks, Alex. I have tried this, but I get the following error: :
Invocation of init method failed; nested exception is
org.elasticsearch.transport.BindTransportException: Failed to bind to
[9300-9400]

I have opened all necessary ports in EC2.


(avasilenko) #4

Probably something is already bound to these ports. Check something like
lsof -i

Alexandr Vasilenko
2011/11/18 achaayan felixmd@gmail.com

Thanks, Alex. I have tried this, but I get the following error: :
Invocation of init method failed; nested exception is
org.elasticsearch.transport.BindTransportException: Failed to bind to
[9300-9400]

I have opened all necessary ports in EC2.


(Shay Banon) #5

If you connect to your cluster on AWS from outside AWS, use transport
client, with sniff disabled (its the default).

On Fri, Nov 18, 2011 at 2:27 PM, achaayan felixmd@gmail.com wrote:

Thanks, Alex. I have tried this, but I get the following error: :
Invocation of init method failed; nested exception is
org.elasticsearch.transport.BindTransportException: Failed to bind to
[9300-9400]

I have opened all necessary ports in EC2.


(achaayan) #6

Thanks.
I have tried this, but I get an exception:

org.elasticsearch.transport.RemoteTransportException: Failed to
deserialize response of type
[org.elasticsearch.action.admin.cluster.node.info.NodesInfoResponse]
Caused by:
org.elasticsearch.transport.TransportSerializationException: Failed to
deserialize response of type
[org.elasticsearch.action.admin.cluster.node.info.NodesInfoResponse]
at
org.elasticsearch.transport.netty.MessageChannelHandler.handleResponse(MessageChannelHandler.java:
126)
at
org.elasticsearch.transport.netty.MessageChannelHandler.messageReceived(MessageChannelHandler.java:
103)
at
org.elasticsearch.common.netty.channel.SimpleChannelUpstreamHandler.handleUpstream(SimpleChannelUpstreamHandler.java:
80)

It would be great if you could provide me some directions.

On Nov 20, 1:27 pm, Shay Banon kim...@gmail.com wrote:

If you connect to your cluster on AWS from outside AWS, use transport
client, with sniff disabled (its the default).

On Fri, Nov 18, 2011 at 2:27 PM, achaayan feli...@gmail.com wrote:

Thanks, Alex. I have tried this, but I get the following error: :
Invocation of init method failed; nested exception is
org.elasticsearch.transport.BindTransportException: Failed to bind to
[9300-9400]

I have opened all necessary ports in EC2.


(Shay Banon) #7

Answered on another thread you opened, I think you use different versions
of elasticsearch.

On Mon, Nov 21, 2011 at 7:39 PM, achaayan felixmd@gmail.com wrote:

Thanks.
I have tried this, but I get an exception:

org.elasticsearch.transport.RemoteTransportException: Failed to
deserialize response of type
[org.elasticsearch.action.admin.cluster.node.info.NodesInfoResponse]
Caused by:
org.elasticsearch.transport.TransportSerializationException: Failed to
deserialize response of type
[org.elasticsearch.action.admin.cluster.node.info.NodesInfoResponse]
at

org.elasticsearch.transport.netty.MessageChannelHandler.handleResponse(MessageChannelHandler.java:
126)
at

org.elasticsearch.transport.netty.MessageChannelHandler.messageReceived(MessageChannelHandler.java:
103)
at

org.elasticsearch.common.netty.channel.SimpleChannelUpstreamHandler.handleUpstream(SimpleChannelUpstreamHandler.java:
80)

It would be great if you could provide me some directions.

On Nov 20, 1:27 pm, Shay Banon kim...@gmail.com wrote:

If you connect to your cluster on AWS from outside AWS, use transport
client, with sniff disabled (its the default).

On Fri, Nov 18, 2011 at 2:27 PM, achaayan feli...@gmail.com wrote:

Thanks, Alex. I have tried this, but I get the following error: :
Invocation of init method failed; nested exception is
org.elasticsearch.transport.BindTransportException: Failed to bind to
[9300-9400]

I have opened all necessary ports in EC2.


(achaayan) #8

Thanks, Shay - changing client jar version fixed this problem. Both
threads described same issues, but on different scenarios.

On Nov 22, 5:39 pm, Shay Banon kim...@gmail.com wrote:

Answered on another thread you opened, I think you use different versions
of elasticsearch.

On Mon, Nov 21, 2011 at 7:39 PM, achaayan feli...@gmail.com wrote:

Thanks.
I have tried this, but I get an exception:

org.elasticsearch.transport.RemoteTransportException: Failed to
deserialize response of type
[org.elasticsearch.action.admin.cluster.node.info.NodesInfoResponse]
Caused by:
org.elasticsearch.transport.TransportSerializationException: Failed to
deserialize response of type
[org.elasticsearch.action.admin.cluster.node.info.NodesInfoResponse]
at

org.elasticsearch.transport.netty.MessageChannelHandler.handleResponse(Mess ageChannelHandler.java:
126)
at

org.elasticsearch.transport.netty.MessageChannelHandler.messageReceived(Mes sageChannelHandler.java:
103)
at

org.elasticsearch.common.netty.channel.SimpleChannelUpstreamHandler.handleU pstream(SimpleChannelUpstreamHandler.java:
80)

It would be great if you could provide me some directions.

On Nov 20, 1:27 pm, Shay Banon kim...@gmail.com wrote:

If you connect to your cluster on AWS from outside AWS, use transport
client, with sniff disabled (its the default).

On Fri, Nov 18, 2011 at 2:27 PM, achaayan feli...@gmail.com wrote:

Thanks, Alex. I have tried this, but I get the following error: :
Invocation of init method failed; nested exception is
org.elasticsearch.transport.BindTransportException: Failed to bind to
[9300-9400]

I have opened all necessary ports in EC2.


(system) #9