Java -d64 Option

I added the "-d64" option to the JAVA_OPTS environment variable in
elasticsearch.in.sh. The following was added:

JAVA_OPTS="$JAVA_OPTS -d64"

When the process is running, I don't see the "-d64" being a part of
the process command. Is "-d64" recognized?

Thanks.

It should work, as it works for the other parameters. I just added it as a
test and its good. Maybe you want to gist how you added it?

On Thu, Jul 28, 2011 at 4:12 PM, Ed Brown VSTI edbrownvsti@gmail.comwrote:

I added the "-d64" option to the JAVA_OPTS environment variable in
elasticsearch.in.sh. The following was added:

JAVA_OPTS="$JAVA_OPTS -d64"

When the process is running, I don't see the "-d64" being a part of
the process command. Is "-d64" recognized?

Thanks.

On Jul 28, 9:38 am, Shay Banon kim...@gmail.com wrote:

It should work, as it works for the other parameters. I just added it as a
test and its good. Maybe you want to gist how you added it?

Shay, in the elasticsearch.in.sh I added this line:

JAVA_OPTS="$JAVA_OPTS -d64"

The following is the process I see:

elastic 4496 1 52 09:27 pts/1 03:16:40 /usr/java/latest/bin/
java -Xms256m -Xmx1g -Xss128k -XX:+UseParNewGC -XX:+UseConcMarkSweepGC
-XX:+CMSParallelRemarkEnabled -XX:SurvivorRatio=8 -
XX:MaxTenuringThreshold=1 -XX:CMSInitiatingOccupancyFraction=75 -XX:
+UseCMSInitiatingOccupancyOnly -XX:+HeapDumpOnOutOfMemoryError -
Delasticsearch -Des.path.home=/opt/elasticsearch -cp :/opt/
elasticsearch/lib/elasticsearch-0.17.1.jar:/opt/elasticsearch/lib/:confused:
opt/elasticsearch/lib/sigar/
-Xms1g -Xmx3g
org.elasticsearch.bootstrap.ElasticSearch

On Thu, Jul 28, 2011 at 4:12 PM, Ed Brown VSTI edbrownv...@gmail.comwrote:

I added the "-d64" option to the JAVA_OPTS environment variable in
elasticsearch.in.sh. The following was added:

JAVA_OPTS="$JAVA_OPTS -d64"

When the process is running, I don't see the "-d64" being a part of
the process command. Is "-d64" recognized?

Thanks.- Hide quoted text -

  • Show quoted text -

Obviously, it works for all the other JAVA_OPTS being set in
elasticsearch.in.sh, since we see them... . Maybe you are changing the wrong
elasticsearch.in.sh?

On Thu, Jul 28, 2011 at 10:39 PM, Ed Brown VSTI edbrownvsti@gmail.comwrote:

On Jul 28, 9:38 am, Shay Banon kim...@gmail.com wrote:

It should work, as it works for the other parameters. I just added it as
a
test and its good. Maybe you want to gist how you added it?

Shay, in the elasticsearch.in.sh I added this line:

JAVA_OPTS="$JAVA_OPTS -d64"

The following is the process I see:

elastic 4496 1 52 09:27 pts/1 03:16:40 /usr/java/latest/bin/
java -Xms256m -Xmx1g -Xss128k -XX:+UseParNewGC -XX:+UseConcMarkSweepGC
-XX:+CMSParallelRemarkEnabled -XX:SurvivorRatio=8 -
XX:MaxTenuringThreshold=1 -XX:CMSInitiatingOccupancyFraction=75 -XX:
+UseCMSInitiatingOccupancyOnly -XX:+HeapDumpOnOutOfMemoryError -
Delasticsearch -Des.path.home=/opt/elasticsearch -cp :/opt/
elasticsearch/lib/elasticsearch-0.17.1.jar:/opt/elasticsearch/lib/:confused:
opt/elasticsearch/lib/sigar/
-Xms1g -Xmx3g
org.elasticsearch.bootstrap.ElasticSearch

On Thu, Jul 28, 2011 at 4:12 PM, Ed Brown VSTI <edbrownv...@gmail.com
wrote:

I added the "-d64" option to the JAVA_OPTS environment variable in
elasticsearch.in.sh. The following was added:

JAVA_OPTS="$JAVA_OPTS -d64"

When the process is running, I don't see the "-d64" being a part of
the process command. Is "-d64" recognized?

Thanks.- Hide quoted text -

  • Show quoted text -

On Jul 29, 2:23 am, Shay Banon kim...@gmail.com wrote:

Obviously, it works for all the other JAVA_OPTS being set in
elasticsearch.in.sh, since we see them... . Maybe you are changing the wrong
elasticsearch.in.sh?

No, that's not it. I really don't understand why it didn't work.

On Thu, Jul 28, 2011 at 10:39 PM, Ed Brown VSTI edbrownv...@gmail.comwrote:

On Jul 28, 9:38 am, Shay Banon kim...@gmail.com wrote:

It should work, as it works for the other parameters. I just added it as
a
test and its good. Maybe you want to gist how you added it?

Shay, in the elasticsearch.in.sh I added this line:

JAVA_OPTS="$JAVA_OPTS -d64"

The following is the process I see:

elastic 4496 1 52 09:27 pts/1 03:16:40 /usr/java/latest/bin/
java -Xms256m -Xmx1g -Xss128k -XX:+UseParNewGC -XX:+UseConcMarkSweepGC
-XX:+CMSParallelRemarkEnabled -XX:SurvivorRatio=8 -
XX:MaxTenuringThreshold=1 -XX:CMSInitiatingOccupancyFraction=75 -XX:
+UseCMSInitiatingOccupancyOnly -XX:+HeapDumpOnOutOfMemoryError -
Delasticsearch -Des.path.home=/opt/elasticsearch -cp :/opt/
elasticsearch/lib/elasticsearch-0.17.1.jar:/opt/elasticsearch/lib/:confused:
opt/elasticsearch/lib/sigar/
-Xms1g -Xmx3g
org.elasticsearch.bootstrap.ElasticSearch

On Thu, Jul 28, 2011 at 4:12 PM, Ed Brown VSTI <edbrownv...@gmail.com
wrote:

I added the "-d64" option to the JAVA_OPTS environment variable in
elasticsearch.in.sh. The following was added:

JAVA_OPTS="$JAVA_OPTS -d64"

When the process is running, I don't see the "-d64" being a part of
the process command. Is "-d64" recognized?

Thanks.- Hide quoted text -

  • Show quoted text -- Hide quoted text -
  • Show quoted text -

On Jul 29, 6:14 am, Olivier Favre oliv...@yakaz.com wrote:

Or maybe you're using the servicewrapper, which does not take the same
configuration file.

I'm using ./bin/elasticsearch to start it. I'm not using a service as
of now.

Servicewrapper uses bin/service/elasticsearch.conf.
But the servicewrapper script (bin/service/elasticsearch) seems at least to
detect this and export it using the DIST_BITS environment variable
(in bin/service/elasticsearch64).

--
Olivier Favre

www.yakaz.com

2011/7/29 Shay Banon kim...@gmail.com

Obviously, it works for all the other JAVA_OPTS being set in
elasticsearch.in.sh, since we see them... . Maybe you are changing the
wrong elasticsearch.in.sh?

On Thu, Jul 28, 2011 at 10:39 PM, Ed Brown VSTI edbrownv...@gmail.comwrote:

On Jul 28, 9:38 am, Shay Banon kim...@gmail.com wrote:

It should work, as it works for the other parameters. I just added it as
a
test and its good. Maybe you want to gist how you added it?

Shay, in the elasticsearch.in.sh I added this line:

JAVA_OPTS="$JAVA_OPTS -d64"

The following is the process I see:

elastic 4496 1 52 09:27 pts/1 03:16:40 /usr/java/latest/bin/
java -Xms256m -Xmx1g -Xss128k -XX:+UseParNewGC -XX:+UseConcMarkSweepGC
-XX:+CMSParallelRemarkEnabled -XX:SurvivorRatio=8 -
XX:MaxTenuringThreshold=1 -XX:CMSInitiatingOccupancyFraction=75 -XX:
+UseCMSInitiatingOccupancyOnly -XX:+HeapDumpOnOutOfMemoryError -
Delasticsearch -Des.path.home=/opt/elasticsearch -cp :/opt/
elasticsearch/lib/elasticsearch-0.17.1.jar:/opt/elasticsearch/lib/:confused:
opt/elasticsearch/lib/sigar/
-Xms1g -Xmx3g
org.elasticsearch.bootstrap.ElasticSearch

On Thu, Jul 28, 2011 at 4:12 PM, Ed Brown VSTI <edbrownv...@gmail.com
wrote:

I added the "-d64" option to the JAVA_OPTS environment variable in
elasticsearch.in.sh. The following was added:

JAVA_OPTS="$JAVA_OPTS -d64"

When the process is running, I don't see the "-d64" being a part of
the process command. Is "-d64" recognized?

Thanks.- Hide quoted text -

  • Show quoted text -- Hide quoted text -
  • Show quoted text -

The -d64 parameter is not working, see:

cheers,

Ingebrigt