Java Error-> NoNodeAvailableException: None of the configured nodes are available


(Nikhil Joshi) #1

I am building up my TransportClient using correct cluster name:
Settings settings = Settings.builder().put("cluster.name", "myClusterName").build();

Everything works perfectly fine when I deploy my Java code and run ElasticSearch on same Linux box. I use localhost when querying ElasticSearch.

When I try to connect ElasticSearch on Linux box using my local windows machine by using LinuxBoxHostName, it throws:
NoNodeAvailableException[None of the configured nodes are available

ElasticSearch.yml file have below entries:
network.host: 127.0.0.1
http.host: 127.0.0.1

Please help me understand how to connect.


(Alexander Reelsen) #2

If you bind Elasticsearch to localhost/127.0.0.1, then you cannot access the service over the network. You need to bind to an IP/interface that is reachable over the network.


(Nikhil Joshi) #3

I had also tried with 0.0.0.0 but it didn't worked either. Anything I am
missing?


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.