java.lang.IllegalArgumentException: is too restrictive


(aaron) #1

Hi I am trying to set the following in the elasticsearch.yml file but keep running in what appear to be syntax issues on version 5.3.2

Here's the yml config:
action.auto_create_index: +-deviceauth-,+-conversation-,+.security,+.monitoring*,+.watches,+.triggered_watches,+.watcher-

which causes the following Error (not I have also tried removing the + symbols (which I read from another thread and this resulted in a different error0

Caused by: java.lang.IllegalArgumentException: the [action.auto_create_index] setting value [+-deviceauth-,+-conversation-,+.security,+.monitoring*,+.watches,+.triggered_watches,+.watcher-] is too restrictive. disable [action.auto_create_index] or set it to [.watches, .triggered_watches, .watcher-history-*]


(aaron) #2

Just in case anyone else get's this issue I was missing a * at the end of the string.: It should have been..

action.auto_create_index: +-deviceauth-,+-conversation-,+.security,+.monitoring*,+.watches,+.triggered_watches,+.watcher-*


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.